Jump to content


A_Jobson

Member Since 25 Jan 2013
Offline Last Active Yesterday, 11:49 PM
-----

Posts I've Made

In Topic: Whine At Low Speeds And Grey Smoke When Accelerating.

05 May 2015 - 06:50 PM

I take it that they didn't address any of these issues when the facelift MK2.5 was released? This seems to affect so many people who have this engine... :(


Sent from my iPhone using Ford OC

In Topic: Loud Rattle After Oil Change

06 April 2015 - 11:00 AM

It does say on the receipt the correct oil was used as agreed, but like mentioned...whether or not they actually used it is something to question.

They did say it requires a low ash oil due to having the DPF filter. No other garage mentioned this. Do you think this could have something to do with that type of oil being used?


Sent from my iPhone using Ford OC

In Topic: Loud Rattle After Oil Change

05 April 2015 - 05:23 PM

Yeah I'm gonna make sure it gets topped up, thanks! :)

It's Fuchs Titan that was put in.


Sent from my iPhone using Ford OC

In Topic: Loud Rattle After Oil Change

05 April 2015 - 01:05 PM

Ahh thank you for that advice, I wasn't sure what these numbers really meant, or how it affected the engine...only that 5w30 is what Ford recommend!

It's only maybe half an inch off the top of the max marking, doubt I'll be taking it to National again though!


Sent from my iPhone using Ford OC

In Topic: Loud Rattle After Oil Change

05 April 2015 - 11:27 AM

It sounds as though that could be what is happening. I just don't get why it would start after an oil change, but be fine beforehand? :(


Sent from my iPhone using Ford OC