Jump to content


ChronixPsyc

Member Since 29 Jan 2013
Offline Last Active Nov 08 2013 06:58 PM
-----

Topics I've Started

Replacing Rear Wiper Motor

08 November 2013 - 06:40 PM

Hey guys,

 

About a month after I bought my car I burnt out the motor on my rear wiper and have finally got round to buying one (ford wanted £160!!!) from ebay.

 

Does anyone have a guide on how to replace this?

 

My model is a Ford Focus Ink 2003 1.6

 

Thanks :)


New Ford Owner And Have A Few Questions

29 January 2013 - 10:15 PM

Hi all,

First time posting here and was hoping you could help me answer a few question as I am not too knowledgable on cars.

I bought a Ford Focus Limited Edition Ink (don't really know what this means, just a different blue?) 53 plate at the start of December and have really enjoyed the car, much better than my previous fiat bravo 51 plate.




My clutch seems high, but the bite is still fine, even on steep hills for stop and start. I had my clutch replaced in my bravo a couple months before I sold it and got my focus so I only think im used to that, but do you think because of it being/feeling so high, I should get it looked at? The guy who sold it to me (friends dads mate who he owns a garage with) said its absolutely fine.

Only noticed something this this morning as I don't usually listen to the radio when driving (use my parrot with phone connected for music), if I change station, the radio just randomly shuts off and takes about 30 seconds for it to come back on. A girl at my work as a Ka and said it also happens to her car. Is this just a normal thing for Fords to do?

Just under a month ago, a bird had crapped on my windscreen and rather than walking back to my house to clear it off with paper, I thought I'd be smart and remove it with the screen wash and hold down the windscreen wipers. This back fired and now my rear window wiper doesn't work at all. Would this be a motor or a fuse problem or something like that? Sorry, I have no idea what I am talking about.

I wanted to use my sat nav a few weeks ago so plugged it in to the cigarette lighter socket and noticed my sat nav wasn't charging. I knew it was working fine because it charged fine in my bravo. Do I just replace the fuse or something? And if so, where would I find it?

When I bought the car, I asked about the timing belt and he told me that it was changed 3000 miles ago, but theres no receipt of this happening. Are there any tell signs of the timing belt going? My engine light is currently on on my dash, could this be related?

Also when I bought the car, the guy told me that the car came with an RS dash with 54k on the clock and 54k on the MOT too, but he wanted to sell the car with a Ford Focus stock dash and it came with 115000 miles on it. Is it illegal to get it clocked back to about 55k? It says on the MOT it was 54k in July when the MOT was done and I've kept record of how many miles I've done since I purchased the car.

Any questions that you could shed some light on would be amazing!

Thanks in advance!