Jump to content


Show

Alec J

Member Since 03 Feb 2013
Offline Last Active Jul 23 2014 10:29 AM
-----

Topics I've Started

Upgrading Stereo

23 July 2014 - 09:25 AM

Looking to upgrade my current Sony 6CD Stereo to a touch screen dvd player one.

 

http://www.amazon.co...&pf_rd_i=468294

 

Can anyone link me to a decent fascia and do i need any loom adapters?

 

Alec


Slight Juddering When Slowing Down In Gear

12 June 2014 - 08:30 AM

Hi guys..

 

Both my Focus's seem to be doing this - Can't say its my driving technique as my other cars previously have never done this.

 

When in traffic or slowing down in say 3rd or 2nd gear the car seems to judder as you hit the 1k rev mark. Once dropping below this the juddering stops. 

Clutch feels fine, drives fine.. no slip if put in 6th gear and floored.

 

Does my head in as i have to sit in at least half hour stop start traffic for work each morning and it makes me want to just coast all the time and instead keep dipping the clutch constantly rather than allowing the car to pull along in gear.

 

Alec


Just Upgraded To A 2007 Focus St!

12 May 2014 - 08:22 AM

Hi Guys.

 

Just upgraded from my 2005 Focus 2.0L Titanium to a blue 2007 Focus ST!

 

Can't wait till Friday when I pick it up, Any cool mods you guys would recommend for it?

Alec


Egr Valve Cleaning

07 April 2014 - 01:47 PM

Hi guys,

 

Could anyone take a photo or point me in the right direction as to the steps of removing the EGR valve and cleaning it?

 

I will make a picture guide once i know how to do this.

 

My EML keeps clocking on every few days relating to: Exhaust Gas Recirculation Control Module - Fault Code.

 

Presuming that is meaning a blocked / faulty EGR Valve.

Alec


Auto Wipers

23 January 2014 - 10:39 AM

Hi guys,

 

Recently i seem to be having an issue with my Auto Wipers.

 

When selecting the first setting UP on the wiper stalk and having the frequency of wipe set to either 1 or 2 from the bottom (Bottom being shortest) i have noticed it sometimes fails to wipe fast enough.

 

At times the screen can nearly become completely streamed of water making it hard to see and you have to manually activate the wipers to clear it. Also sometimes it will stay on intermittent when clearly it should be on fast.

 

Never use to have this problem, only started seeing it recently. Maybe the cold has something to do with it?

 

Sometimes it works perfect and switches fast to slow etc no problems.

 

Alec