Jump to content


Kempfab

Member Since 03 Feb 2013
Offline Last Active Apr 10 2013 08:47 PM
-----

Posts I've Made

In Topic: Lh Rear Speaker Not Working

03 March 2013 - 06:18 PM

I guess they buy those speakers by the boat load for pennies, and three rivets takes seconds to fit.

 

Going by all the stickers inside the door, and name pressed in to the metal, they are designed/manufactured by a sub-contract specialist firm.

 

No different to Bosch, Recaro, Hella etc.

 

Cars are just business, and not a very profitable one these days.

 

Still, it keeps us amused putting all these things right!


In Topic: Lh Rear Speaker Not Working

03 March 2013 - 04:38 PM

I cut my old speaker up, going to have a play at work tomorrow, because I think you could use the frame bit as a speaker adaptor, and if you save the right bits, still use the existing loom wiring, and then just solder the new speaker leads after the Ford connector.

 

Not sure that made any sense?! I will have a play, and take some pics. This was an after thought, so may try it on the other side one, as I cut the part off my left hand one that holds the terminals in place...

 

If it works though, you would not need to buy the adaptors, that don't really fit, anyway...

 

Also, I hope to fit some rivnuts, instead of rivets, as we happen to be using lots at work at the moment!

 

Good luck with yours!


In Topic: Lh Rear Speaker Not Working

03 March 2013 - 12:57 PM

Yeah, no need to go that deep!

 

I guess the taped up speaker extension wire is for a tweeter, on ghia/titanium perhaps?


In Topic: Lh Rear Speaker Not Working

02 March 2013 - 08:06 PM

Sorry for delay in update, work a bit silly at mo...

 

I could not fit speakers to the parcel shelf, as it is rarely in the car, she's a van most of the time!

 

Tried old stereo, same speaker still out, so removed door card, after buying forked tool thing.

 

Un-plugged speaker, and checked cables to stereo with multimeter, all good, so dead speaker it is.

 

Bought a cheapy pair off ebay, complete with connect2 adaptors.

 

Drilled off rivets, removed speaker, bit disapointed the adaptors don't quite line up with the holes...

 

Anyway, bit of cable re-routing, soldered on new terminals from the wires that came with the speakers,

all good now! Shame I forgot to bring my rivet pliers home from work though...

 

Whilst on a roll, managed to finish wiring in my 12v boot socket, and a second boot light, a very successful day by my usual standards!


In Topic: Lh Rear Speaker Not Working

14 February 2013 - 06:17 AM

I will check the radio end first, I was hoping for a flood of 'yeah, they always break here' etc!

Think I will drop the old stereo in too, to make sure it is not a stereo fault.

I will update after I get time at the weekend to go digging.

Cheers for the ideas so far, keep em coming!