Jump to content


malcy666

Member Since 20 Feb 2013
Offline Last Active Jun 28 2013 11:31 PM
-----

Topics I've Started

Just Bought Ford Mondeo Titanium X Sport And Warning Light

20 February 2013 - 05:49 PM

Hi all,
I have just bought a red 2009 ford mondeo titanium x sport 175 and im really pleased with it,awsome car.
I had a audi sline 170 and the clutch went and i have never looked back.
I have not had mondeo long and bought it from auction is was a finance repo,it has 34000 miles on it.
Runs lovely and sounds nice but every time i start if the engine malfunction comes up and i click ok and it goes away but left with a amber information warning light and spanner so i presume it needs serviced.
I went to a mechanic but he cant look at it for 2 weeks so is it safe to drive normally like this?.
No weird noises or loss of power the car seems great.
Any help would be appreciated.
I will get some pics done when i get the chance

Bought My First Ford

20 February 2013 - 05:38 PM

Hi All,

Well i have just bought a Red 2009 ford mondeo titanium x sport 175 with 34,000 miles on it.
My audi clutch went and thought oh well what will i get and seen this at auction and bought it.
It runs really nice and feels much quicker than my audi sline 170 ever was and the mondeo drives
better also i have to say.
I know it needs a service which i will get round to but every time i start the car it comes up with the message engine malfunction then i click ok and the warning light goes to information amber but it is stored in messages.
The engine seems very smooth and refined and pulls like a train so wonder what this could be?,any idea guys.I went to book it in today and was told i would have to wait about 2 weeks so i will drive it carefully as everything seems fine,you guys think that would be ok to do or not?.
Anyway im happy to be a proud owner of this stunning machine i cant believe the extras its got as in touch screen sat nav and hill assist its amazing and huge inside.
Look forward to your replies