Jump to content


michael.n

Member Since 07 Mar 2013
Offline Last Active Jun 07 2015 04:53 AM
-----

Topics I've Started

Fiesta Mk7 1.6 Tdci 95hp Econetic Slow 1st Gear

04 June 2015 - 08:34 AM

Hello everybody ! Congrats on the fine community you've managed to build here and I can say I'm really glad to join you.

 

Two months ago I bought a used 2010 Fiesta Mk7 with a 1.6 TDCI 95 HP engine
(econetic). The car has roughly 50k miles and is in pretty good shape,
with one exception. It's really slow in 1st gear. I've read online that due to the transmission, the engine tends to be sluggish in the first two gears, but mine is literally crawling in 1st. I've driven quite a few other cars with the same engine before buying this one, but the others were faster. In other gears, mine pulled similarly, maybe just a tad slower.

 

I've had it serviced, I've changed the oil and filters and the mechanic was
pretty content with the state the car was in. He said there was nothing
wrong to it and the sluggishness may be due to the way the car was
driven before, having had a female owner who drove it mostly in the
city. I went to another mechanic, who dismissed me right away saying the
car wasn't made for racing and was slow by design. He tested the clutch
though and said it was ok.

 

I'm considering a remap, but I'd like to sort out the problem before so I can fully enjoy
the capabilities of the car. What could be wrong with my car ? What
should I check next given the fact that the mechanics I've been to have
run out of ideas ? Thanks in advance.