Jump to content


Show

ben1191

Member Since 08 Apr 2013
Offline Last Active Aug 18 2014 09:26 AM
*****

Posts I've Made

In Topic: Engine Systems Fault On Dashboard

17 August 2014 - 07:31 AM

If your not getting any codes atall I'd think the display dash things broken (can't think of the name of the !Removed! part lol )


Sent from my iPhone using Ford OC

In Topic: Engine Systems Fault On Dashboard

17 August 2014 - 07:30 AM

Yeah the focus,or mine atleast,seems to suffer from water gettin into stupid places,aerial,boot release footwells and fuse box seem to be the main ones.systems fault is usually somethjng more than a leak but it could be a hundred things really ,better off getting it read by a proper machine as the handheld ones we use unless they're expensive ones won't pick up every code.


Sent from my iPhone using Ford OC

In Topic: Has Anyone Had The St250Rs Kit On Their Focus St

16 August 2014 - 04:12 PM

Yeah but the going rate of an rs is about 15k,and they're only 320bhp? Think it's more around 310 the rs500 is 350bhp.goig rate of an st225 is like 4-5k? I'd rather find one with a dodgy turbo or blown one and then get this done to it(assuming they're changing the turbo out?) either Way,personally when I get my focus st I'll keep it until I own a focus rs or maybe some super quick mondeo If they ever make one .


Sent from my iPhone using Ford OC

In Topic: Has Anyone Had The St250Rs Kit On Their Focus St

16 August 2014 - 02:06 PM

i dont,but that looks brilliant :D Cant wait to get my ST one day when the insurance fairies decide im allowed lmao


In Topic: Engine Systems Fault On Dashboard

16 August 2014 - 01:58 PM

I was told that the dash where the speedo is etc,that a solder on the back cracks pretty often and can cause it?not too sure though

 

its weird that youre getting no codes from a code reader too.