Jump to content


MrsEaton23

Member Since 19 May 2013
Offline Last Active May 23 2013 09:37 PM
***--

Posts I've Made

In Topic: Speedo Drop To Zero, Engine Man Light, Battery Light And Fuel Light Came On.....

23 May 2013 - 09:25 PM

And hey!! I aren't ignoring anyone :) I told the mechanic three times what you guys have said about the vehicle speed sensor and he kept brushing me off. I'm a complete novice and trying to keep up with the mechanics lingo and also trying to understand the theories behind the things that are happening. :)

In Topic: Speedo Drop To Zero, Engine Man Light, Battery Light And Fuel Light Came On.....

23 May 2013 - 09:17 PM

Do I feel a prat now!!

Car died about 20minutes after I posted that last post. Won't turn back on. Again.

Anyone want it £300 spares repairs hahaha!

I'm really worried now that it's crank walk. If the crank is chewing these crank sensors up then it's fooked. The mechanic has said he was 'hoping it wasn't the plate' and I thought... Wonder what he means? So I did a bit of reading n research around it and voila - big fat threads on crank walk. It explains why my crank sensor slowly got smashed to bits and the symptoms got worse and worse over a few weeks.

But if the plate is basically smashing into the sensor with every rotation and that wasn't fixed, it's only took 6 miles of driving to smash through a brand new one.

Think I might full on cry!!

In Topic: Speedo Drop To Zero, Engine Man Light, Battery Light And Fuel Light Came On.....

23 May 2013 - 03:37 PM

Hey everyone!

 

Got some news for you (touch wood) its fixed!!

 

Yesterday, the mechanic came to look at it again after the power failure I told you about. Well, he put new spark plugs in it, new air filter and oil filter and he called me to say it was running great! He said he'd drop it off for me before work, but he never arrived.

 

I got a call from him saying that he got about a mile away from my house, doing about 45mph and it just completely died, all the usual things happened, power steering went, brakes failed etc. He said he caused a huge traffic jam because someone almost hit him as it kind of careered into the other lane. He managed to push it into a bus stop in the end. It wouldn't turn over at all. Nothing. Dead as a dodo. All it showed was an amber engine management light. They towed it back for diagnostics and it came back that the crankshaft sensor had failed!

 

You should have seen the state of that crankshaft sensor! it was snapped in the middle and had a broken tiny copper wire in it all shrivelled up! Looked a right state!

 

So, all the work is now done. Air filter, fuel filter, spark plugs and a crankshaft sensor. Drives like a brand new car! CRAZY


In Topic: Speedo Drop To Zero, Engine Man Light, Battery Light And Fuel Light Came On.....

21 May 2013 - 08:28 PM

Hi everyone.

Just thought I'd update you on the fun and games I'm having with this issue.

Mechanic I know has done me a massive favour and picked my car up for me yday morning and took it for diagnostics. No codes/errors found.

He found the 'breather' pipe blocked? Something to do with creating a vacuum in the fuel tank he was saying. He also found the pipe that the TPS fitted to all blocked up with carbon and he said that explains why it was reading the TPS was faulty weeks ago. So essentially it's had a new TPS for no reason.

He cleaned all that out and now it drives like a sports car, really keen and sharp and quick. I was majorly impressed and it feels much happier.

Drove it home today and guess what!? The speedo dropped to zero and I lost about 50% of power, it didn't matter how much accelerator I gave it, the car wouldn't go over about 1800rpm. It just died and it got to about 30mph max. The whole time, the speedo was dead.
Then all of a sudden, the speedo jumps back into action and the car revives itself and got full power back!

What the HELL!??

In Topic: Speedo Drop To Zero, Engine Man Light, Battery Light And Fuel Light Came On.....

19 May 2013 - 05:53 PM

Okay guys, just took it out for a spin with my neighbour to see if it would replicate the fault and it did it 4 times in about 2 miles. It cuts out completely at junctions and at slow speed now.
I'm getting a bit emotional now ;) women aren't meant for this diagnostics fun ;)