Jump to content


mrHman

Member Since 19 May 2013
Offline Last Active Apr 20 2014 08:28 PM
-----

Topics I've Started

Engine Bogs Down When Using Electrics

24 June 2013 - 01:41 PM

Hey ppl...Need help addressing this issue in my mk1 focus 1.6...whenever im sitting still with engine idling and turn on any sort of electrical device e.g. rear screen heater or even rolling up auto windows. The engine will just bog down and grumbles like its low on power.....I was thinking about changing the battery or alternator but cant decide what would be best. I still have the standard focus battery in if that helps.....any ideas?

Help Fitting Mk1 Mudflaps

23 June 2013 - 03:40 PM

Hey ppl, installed my genuine ford mudflaps today for the rear with no issues. However I need help with the fronts...the metal clips just keep sliding off whenever I fix them on. E.g. if I move the mudflap then it will slide off....not sure if im doing it right.....anyone got any guides or pictures?

Paint Restoration

15 June 2013 - 05:14 PM

Hello again ppl. Decided since the weather has been gettin abit better recently that maybe I should try to restore my 04 focus paint. Ive got a few marks on the paint I would like to remove. Just need help choosing the right product.

Obviously t cut is out there but ive heard its only for old paint jobs and will mess up metallic paint jobs. Or theres t cut colour restoration which ive heard is more of a temporary fix. So not sure as to what product to buy..

I have a moondust silver 04 focus of that helps lol

Hid Advice

28 May 2013 - 07:35 PM

Hey ppl, im looking after some HID's for my mk1 facelift. There's two things holding me back though. 

 

1. Someone told me HID's are illegal if you don't have auto adjust headlights and headlight washers

 

2. If the above isn't true then i need help choosing H7 HID's cos there's a shedload on ebay so i cant really choose and I dunno what brand is the best or most reputable.

 

Soo help me plz???


Clutch Squeal When Moving Off

22 May 2013 - 09:52 PM

Hey ppl I need help. Iv noticed that when moving off in 1st, when bringing the clutch up to biting point, the car makes a slightly high pitched 'wheel spinning' squealing noise. Im bringing the biting point up quite slowly with more than enough gas. I have the mk1 1.6 and its done 80k.

Any help please?