Jump to content


Member Since 11 Jun 2013
Offline Last Active May 15 2015 07:28 PM

Topics I've Started

Help With Leisure Battery?

27 March 2015 - 10:50 PM

Hi everyone can someone help me out i have an old caravan that gets used not very often ive just discovered the leisure battery is flat as theres no means of charging it on the caravan the battery is 18 months old numax 100ah ive tried charging it up with a 4 amp charger and its taken well over 25 hrs (100/4=25) without it being fully charged (according to the charger indicator) do i just leave it on charge until the charger says its charged or not the battery is making a faint but audible hissing noise??



Can I Park Here

14 February 2015 - 07:12 PM

Im staying in a hotel that charges £1.50 an hour for parking!
Across the road theres parking bays can I park in these after 6:30 on Saturday signs pics below I get confused easily lol

Focus Interior Light Problem?

11 February 2015 - 11:28 PM

So changing a light bulb in the dark  :unsure:


I think ive either broke or lost a part of my interior light the button/switch flew off while trying to replace the bulb and i thought i had put it all back together properly but i didnt its switches on and off but is also constantly on when in the middle setting (when it comes on with the doors opening) is there just the button with the copper bits poking out the back or should there be other bits in there?


To make matters worse i also swapped the ignition live and dash illumination wires from the canbus adaptor for my head unit direct to the quadlock as i was having problems with an aftermarket head unit. Im hoping this is not related!



Should I Be Worried?

08 February 2015 - 01:37 PM

Should I be worried about this white stuff in my oil filler cap, Always got told it was bad but cars been fine.
Changed oil oil filter plugs and cleaned k&n today oil was very black was changed 6 months ago only did about 4k not using oil or water either

Odd Noise, Alternator?

03 December 2014 - 09:59 PM

My mrs started the car up earlier (mk2.5 2009 1.6 16v petrol) and with headlights on front and rear heated screen on blowers on there was a definate clicking/rattling noise coming from the aux belt area, turning the heated screens off made the noise disappear which makes me think its the alternator under heavy load anyone else had this happen?


I had to take my boy rugby training and she was taking me girl to dancing so couldnt really have a look and its too cold and dark to get out there to go out with a meter now any ideas? it runs fine normally btw