Jump to content


Show

caffeinehigh

Member Since 18 Sep 2013
Offline Last Active Dec 30 2013 06:02 PM
-----

Topics I've Started

Power Steering Problem

09 December 2013 - 07:56 PM

Twice now I have been reversing with full left lock on to park and heard a clunk followed by the steering dying to the point where the wheel won't move either direction. A few seconds later it comes back on and I can finish parking. Today the same thing happened again but instead of a clunk I could hear what I can only describe as almost a hissing noise. 

 

Is this likely to be the power steering pump on its way out? If so any ideas what it is likely going to cost for it to be repaired? :( Car still works by the way, this only seems to happen for a few seconds when I have full left lock on and then it works fine again. 


Mk1 Focus. Anyone Changed The Stereo?

05 October 2013 - 07:24 PM

I'm thinking of changing the stereo on my MK1 focus. But since the standard stereo is slightly curved I'm thinking it might not look right. Has anyone who has done it got some pictures so I can get an idea of how it looks? 


Engine Management Light Never Comes On

18 September 2013 - 07:22 PM

I have noticed the engine management light on my 2003 Focus never comes on when I turn the ignition on or ever. Is there anything that would cause this? Maybe something needs resetting? 

 

I did a bit of research and held the trip reset button while turning the ignition on. The code that pops up is 969E. With the 6 being backwards as show in the picture below. I can't seem to find anything on this though. Any ideas?