Jump to content


Steelman

Member Since 07 Mar 2009
Offline Last Active Feb 27 2010 04:13 PM
-----

Posts I've Made

In Topic: Slight Mis-Fire

27 February 2010 - 03:21 PM

[b]Hey Guys!!! I know I was going to wait 'till Tuesday but, it got the better of me. So, I bought a new coil pack & HT leads (48.76) It took me 10 minutes at the most & hey, look at me!!! the newby mechanic has fixed it!! Car goes like it should with no hesitation at all. Hope this helps anyone with similar probs & thanks again for all your ideas. Regards PETE :D :D

In Topic: Slight Mis-Fire

27 February 2010 - 09:25 AM

:)Guys, thanks for all your interest. I've got the car booked in to a garage that I've used for years. They're good lads & now that I WILL & have checked their work before & I'm lucky that they're good guys to me. It's booked in for Tuesday so I'll report back on the findings!! Thanks again for your help, Regards PETE :)

In Topic: Slight Mis-Fire

26 February 2010 - 07:40 PM

Thanks for that. It had full service in December but I'll get plugs changed as well. Any idea how much I may be looking at ? Thanks PETE

In Topic: Rear demisting/heated screen.

18 January 2010 - 04:17 PM

No. I think the answer lies with a broken connection somewhere, but hey, thanks for your ideas anyway. Regards PETE

In Topic: Rear demisting/heated screen.

16 January 2010 - 08:36 PM

Had a good look at the glass & all I can see is very very small, what look like burn marks, on three of the lines. I've bought some of the liquid mentioned & I'll give it ago later. Thanks for all your help.