Jump to content


BLACKHAWK145412

Member Since 01 Dec 2013
Offline Last Active May 25 2015 09:05 PM
-----

Topics I've Started

What Do You Guys Think?

18 May 2015 - 03:14 PM

Made in GIMP because I'm too cheap for Photoshop :D

gallery_48603_1336_196668.png


Exhaust Smells Of Petrol - Running Rich?

23 April 2015 - 11:30 AM

Hi all,

 

Started to notice that the exhaust fumes of my car smell strongly of unburnt petrol. This still occurs when the engine is up to running temp and the choke is not being used. Is this simply because the car does not have a catalytic converter? Are there any other symptoms of a rich mixture? Also, regarding mixture adjustment, the Haynes manual mentions some kind of tamper-proof seal on the carburettor; does anyone have any info on how to deal with that? I believe it is a Weber 2V TLDM carburettor.

 

Much appreciated


Eclipse Pictures

20 March 2015 - 10:07 AM

Hey guys, just wondering if any of you got any decent photos of the eclipse today?

 

Here are mine:

 

WP 20140309 008
20150310 164533
20150310 164337
 
;) Just kidding here's a real one that's not very good:
 
20150320 092915

 


Finally Replaced My Gauge Faces

12 June 2014 - 08:10 PM

Took a couple of attempts, but I now have functioning gauges and the faces are not flaking off! First I ordered a whole new instrument panel from an old XR3i, but it turns out the inner workings were changed completely around '88, so only the speedo was useable. I disassembled that and swapped my original odometer in to keep the mileage.

 

Luckily, it turns out that the fuel/temp gauge faces are nearly exactly the same for early Mk5 Escorts, so I was able to get one from a breaker's yard, and after some careful trimming it could be fitted.

 

Here are some pictures of the end result:

med_gallery_48603_1336_169842.jpg

 

 

med_gallery_48603_1336_227224.jpg

 

 

med_gallery_48603_1336_31645.jpg