Jump to content


Show

CharliEngine89

Member Since 02 Jan 2014
Offline Last Active Feb 01 2014 05:20 PM
-----

Topics I've Started

Electical Mayhem! Keyless Crazyness! Mk2 1.8Tdci

03 January 2014 - 10:20 PM

So here's the problem/s.

I have a 2006 Focus 1.8tdci Sport that is having some electrical issues that I believe are all connected.

1. Parasitic draw attributed to LCD display in intrument panel not switching off, also radio module shows 0.3A draw when car is off. Possibly linked to possibly faulty micro-switch in ignition barrel. Car not going to "sleep". I have reduced the drain by removing the instrument panel fuse and replacing with a switch. Not eliminated however.

2. Boot unlocks itself at any given moment. Happens when locking/unlocking car generally. I have had trim off and have checked for water damage, found some evidence of water ingress on boot hatch switch connections; cleaned corrosion and dried thoroughly. Removed and refurbed the locking mechanism. Problem persists.

3. When steering lock in engaged there is a clicking noise that immediately comes from the radio unit for the keyless entry system. See photo. That continues to click for as long as the steering lock is engaged.

Attached File  1388786987427.jpg   48.27KB   18 downloads

4. The car unlocks itself while off...sometimes.

I am a confident mechanic and am an engineer by trade working nearly daily with electronics but for the life of me I cannot trace the root of this fault.
Just for added info; the engine ecu was replaced by Ford due to water damage in May. Problem existed before that and after.

Can anyone advise? Anyone with a similar experience? I can't be the only unlucky sod about :S



Sent from my GT-I9300 using Ford OC mobile app