Jump to content


Show

mikeywalker1967

Member Since 30 Jan 2014
Online Last Active Today, 11:57 AM
-----

Posts I've Made

In Topic: Brake Fluid Colour

16 July 2014 - 12:06 PM

My brake fluid was changed on a month ago and has gone black in that time.
Is the clutch hydraulic and does it use the same reservoir as the brakes

Sent from my GT-I9300 using Ford OC mobile app

In Topic: Rear Wheel Bearing....

05 May 2014 - 12:22 PM

Can get them out.
Use the old lock nut as you get a new one spray lots of Wd40 on bearing a use a large socket and a big hammer.
To fit new one put it in the freezer for a while and use the old bearing carraige to hammer it in .
Did both rears on my fiesta.

Sent from my GT-I9300 using Ford OC mobile app

In Topic: 58 Fiesta 1.4Tdci Engine System Fault Light On Dash Intermittent

12 April 2014 - 11:41 AM

Could be Egr valve sticking.
Mine was going in to limp mode but when you switched off full power restored.
No faults on Dtc.
Replaced valve ,jobs a good un.

Sent from my GT-I9300 using Ford OC mobile app

In Topic: Noise When Turning At Low Speed

03 April 2014 - 09:10 AM

I used to have a vw polo that was doing the same but it was a plate behind the brake disc that used to catch stones and would rub against the disc.
I take it your ford doesn't have a plate behind the disc..
Could be top mount of the shock absorber thats gone dry .
Try squirt some wd up the shocker.

Sent from my GT-I9300 using Ford OC mobile app

In Topic: Turbo Charger Loss Of Boost

22 March 2014 - 07:05 PM

My fiesta was doing the same thing and it was the Egr valve sticking which was putting it in to limp mode.

Sent from my GT-I9300 using Ford OC mobile app