Jump to content


PedroG

Member Since 30 Jan 2014
Offline Last Active Mar 03 2014 01:43 PM
-----

Topics I've Started

1000 Ecoboost Real World Mpg

03 February 2014 - 12:56 PM

My C Max 1000 ecoboost had 10000 on the clock when I bought it, so I'd expect it to be well run-in and to be getting the best mpg I'm likely to get, however I'm getting 36/38 with a mix of mainly country roads and some town driving.  Expected more, based on claims of 54 from the manufacturer, thought I'd maybe get around 45/48. The dealer I bought it from said I should be getting more.

Any suggestions as to how I can improve this?

 

Thanks

 

:rolleyes:


Radio/satnav Screen

30 January 2014 - 02:50 PM

I'm wondering if this is a fault or not.  When the radio is off the screen has a series of blue rectangles on it, as if it was still on but the brightness was turned up too high.  I thought it would have been dark or at least all one colour.  When the radio is on there's a graded blue effect, lighter at the top and bottom of the screen.  When the SatNav is on there is a lighter band at the top of the screen.  It looks sort of 'washed out', not good contrast and as if the brightness was too high.  I don't have auto lights so only have the instrument light dimmer but that doesn't have much effect. I've looked in the settings but can't see any way of adjusting the screen settings.

 

Any help appreciated.


New Member

30 January 2014 - 02:34 PM

Hi

 

Just bought a 2013 plate C Max Ecoboost recently, nice car, great to drive, bit disappointed with the mpg but haven't had it on a really long run yet.

Looking for a bit of advice with the display screen but will see if I can find a suitable thread to post it in.

 

Happy Motoring