Jump to content


Show

jc1968

Member Since 17 Mar 2014
Offline Last Active Apr 03 2014 04:28 PM
-----

Topics I've Started

Break Fluid Filler.... Yellow Cap

30 March 2014 - 04:37 PM

Hi

I noticed today that where you fill up the break fluid seems to be missing a piece. right now it is like a plunger.... a thing that I can push down but when looking at google images there is missing a yellow cap, or thats what it looks like

the breaks work ok so do i even need this missing part and what is it and what is it for?

Thanks

Another Over Heatinb Problem.... Baffled

30 March 2014 - 04:23 PM

Hello

I have just bought a 2000 1.5 Fiesta Ghia that has a zetec engine. I have been having intermitant over heating problems and while not a mechanic I can find nothing similar in my searches and had a mechanic look at it today who was left unsure of what the problem may be.

Thermostat is working as tbe radiator is getting hot. the hoses to top and botton of radiator are getting hot

When the car overheats I ha e found that I have had to put in around a litre and a half of water but at other times the water level is spot on... there are no signs of leaks

the heater gagss in the car areall set to cold... but the car gets very hot (open window time)

oil is all clean so no water getting into head

I can drive all day around town and up motorway and have no problem... then it can overheat again with no notice

the temp gauge can go right into the red and then back down to mid way ( a yoyo effect)

the radiator fan kicks in most of thd time.... not sure if its supposed to in normal running

The car is fine while running at standstill and temp gauge sits easily mid way

Im not sure what to look at next so if someone could help that would be great.

Thanks