Jump to content


michaelhayler17

Member Since 20 Mar 2014
Offline Last Active Yesterday, 10:11 AM
-----

Topics I've Started

Direnza Hoses...

29 July 2015 - 10:25 AM

Hi all, i have a split coolant hose and thought it must be time to upgrade to silicone jobies. After a root around i found that almost no where does silicone hoses for my car. I have a 1.8 mk2 pre facelift and asking around finding anything for this car is like trying to buy chicken lips! But after almost giving up i found this kit. All it said was focus 00+ 1.8 & 2.0

Now very suspect of these being any good i just went on the pictures and they did LOOK like the majority of the hoses in my car. So like a mug i have ordered em, after all my car is leaking so i need sumit to replace anyway.

I have now just recieved a invoice where the part is listed as 2.0 02-04 hose kit... Very unimpressed.

But to the point has anyone ever heard of this lot? Has anyone bought stuff from them? Did it fit/work? And after you found out they sent you the wrong stuff, how easy was it to send back!?

And replys welcome, thanks.

P.S, after all this, if ive posted this in the wrong place im gonna just leave lol!!

Focus Mods.

25 May 2015 - 05:26 PM

Just a question about parts really, i have a mk2 1.8 focus and would like to change the cooling hoses for silicone ones, now ive seen mountune do cooling hoses but for the ST/RS will these not fit on my car? If this is the case is it because there engine layout is different to mine, by being a bigger cc, and if so would that b the same again for throttle bodies and cams etc etc...

Egr Blanking Plate On A Petrol Engine.

18 May 2015 - 08:54 AM

Ive fitted an EGR plate to my car and was "aware" that an engine management light would come on. Just to make sure with those that have done it, it was this light that comes on yes?

Oil Pressure Gauge

15 May 2015 - 11:02 AM

Hi all! I posted in the past of oil light issues, so braved the decsion to fit a gauge... the b*****d thing wont play ball. It either stays on flat zero or during acceleration shoots to the other end of the gauge n the oil light comes on. I feel this is a sender problem, if so would anyone know how to fix it? But, saying that, what would the "normal" pressure be? Just in case a reading over 100 psi is standard... :)

Help Please, Galaxy Fire!

02 April 2015 - 02:49 PM

Hi all, hope this is roughly in the right place. Long story short my friends galaxy caught fire, after a service, and is history now. Just wondering if this has happened to anyone else or if anyone knows if this has happened else where. Trying to figure out what has caused this to happen.