Jump to content


BryzeMo

Member Since 23 Mar 2014
Offline Last Active Jan 04 2015 09:15 AM
-----

Posts I've Made

In Topic: Fiesta Fuse Keeps Blowing

04 January 2015 - 09:19 AM

Hi Troy. Just to keep u posted but i managed to fix my problem. Turns out my tail light bulb was faulty and that was what was blowing the fuse every time. Thanks for the info bud
Bryan


Sent from my iPhone using Ford OC

In Topic: Fiesta Fuse Keeps Blowing

01 January 2015 - 07:00 PM

Thanks again Troy for the info. Gonna try this at the wend.
Thanks
Bryan


Sent from my iPhone using Ford OC

In Topic: Fiesta Fuse Keeps Blowing

31 December 2014 - 03:52 PM

Hi Troy. Thanks for the info. Will check if the motor runs or not with no fuse. Do u know if there is a way to disconnect these from the circuit? Never use them n thats a cheaper option at the moment as headlight clusters aint cheap!

Thanks
Bryan


Sent from my iPhone using Ford OC

In Topic: Gear Change Issue

15 October 2014 - 08:36 PM

Just to update. I went and removed the shift lever and cleaned up the nylon bushes and also cleaned the pivot stem. Greased everything up and hay presto smooth gear changes. Thanks for ur help DieselPig.

Thanks
Bryan


Sent from my iPhone using Ford OC

In Topic: Gear Change Issue

09 October 2014 - 07:05 PM

Thanks DieselPig
I found another thread where it might be the shift arm on the pivot shaft that need opened up slightly and greased. Apparently this is a common fault with the mk6 fiesta when everything gets warm. Gonna try these suggestions at the wend
Thanks
Bryan


Sent from my iPhone using Ford OC