Jump to content


Jaynie91

Member Since 03 May 2014
Offline Last Active Jun 12 2014 12:58 PM
-----

Topics I've Started

Trailing Arm Bushes Seized 1999 Fiesta

11 June 2014 - 02:11 PM

Hello,

 

Just a quick question if anyone has any ideas, we are trying to replace the trailing arm bushes on my 1999 Fiesta however it would seem that nothing has been changed on my car since it came out the showroom as most things take a lot of brute force to get out. We don't have a bush puller or whatever it is called and going by the Haynes guide has helped us get to the stage of taking out the bushes but it would appear that one bolt had seized, which we have managed to get out to drop the axel, however now the bushes appear to be seized in the axel. Any ideas how we can get them out?

 

I have seen one step by step online with seized ones where they used a hacksaw to cut through everything then used the bush puller to pull the bush out, however we do not have one and they appear to be really stuck in there, so really any ideas on how to get them out, I have managed to cut nearly through one of them but with another one to go, any advise would be great.

 

Thanks

Jaynie


Engine Management Light On And Misfiring

10 May 2014 - 01:22 PM

My friend has got a Ford KA, 2003, which the engine management light is on and the car is juddering as soon as the engine is turned on.

 

They have changed the spark plugs and coil pack as per recommendation from a garage however it still has the problem. The HT leads haven't been changed however they are still sparking.

 

Has anyone else had this problem?

 

Thanks

Jayne


Fiesta Hazard Lights And Horn Not Working

03 May 2014 - 09:55 PM

Hello,

I have a T Reg/1999 Ford Fiesta Mk VI. I needed a new headlight and so we got one from a scrapyard to replace the one I had, which had to be changed due to my partner hitting a pheasant and it broke part of the plastic housing and was held in by 1 screw. We had replaced the passenger one from a scrapyard one before and know how to change one however as we went to replace it, I was checking the lights and the indicator started clicking a lot then suddenly stopped, no indicators, no clicking, no hazards.

We have checked the fuses and the one for the indicators had blown, so we changed it and to begin with had no luck. We then changed the flasher unit on the steering column and seem to have the indicators working but the hazard lights wont work and neither will the horn, which I have the understanding that they work off the same switch.

We have checked the fuses again, all of the ones in the engine and by the steering wheel, we have checked and changed the relays and even tried another hazard light switch from another fiesta but it doesn't seem to work. The horn still works as we have tested this but we don't know what could be causing the hazards to not work. We have also been looking in the Haynes manual and found they are both off the multifunction switch.

Any ideas or help would be great.
Thanks
Jayne