Jump to content


hondacr250

Member Since 23 Apr 2009
Offline Last Active Oct 29 2009 09:57 PM
-----

Posts I've Made

In Topic: Battery warning light

27 April 2009 - 12:23 PM

Hello,
I have a problem with my Ford Mondeo 2002 2Litre TDDI, The alternator in the vehicle failed and a brand new one bought from the Dealer was fitted by an electrician. Although the new alternator is charging and the car is running sound, I have the battery warning light that comes on about 20 seconds after I start the engine. I also noticed that when this light is on, the front heated windscreen doesn’t light up and function.

Almost 2 years ago, a new alternator was fitted in my car and I had same problem (I am a night time taxi driver therefore the alternator keeps failing due to electric surcharge). I took the car to the dealer and they found a fault in the wiring loom.....I was charged £245.

Any suggestion what this wiring loom can be?? any help will be very appreciated

hi i have a focus st170 and mine is doing the same as yours - changed alternator and light is still on. i have had a few people message me back with -a bad earth in the car? dodgy alternator and battery well mine is none of those. my car is in the garage at the moment to see if they can find the problem so ill let you know.

In Topic: Battery warning light

27 April 2009 - 12:22 PM

Hello,
I have a problem with my Ford Mondeo 2002 2Litre TDDI, The alternator in the vehicle failed and a brand new one bought from the Dealer was fitted by an electrician. Although the new alternator is charging and the car is running sound, I have the battery warning light that comes on about 20 seconds after I start the engine. I also noticed that when this light is on, the front heated windscreen doesn’t light up and function.

Almost 2 years ago, a new alternator was fitted in my car and I had same problem (I am a night time taxi driver therefore the alternator keeps failing due to electric surcharge). I took the car to the dealer and they found a fault in the wiring loom.....I was charged £245.

Any suggestion what this wiring loom can be?? any help will be very appreciated

hi i have a focus st170 and mine is doing the same as yours - changed alternator and light is still on. i have had a few people message me back with -a bad earth in the car? dodgy alternator and battery well mine is none of those. my car is in the garage at the moment to see if they can find the problem so ill let you know.

In Topic: battery light

27 April 2009 - 12:14 PM

first thing to check would be that you have 14.5 volts at the battery terminals with the engine running, also the alternator connecting clip can throw up problems.

i have had it all checked and the battery is charging. is the alternator connecting clip the one that is on the top of the alternator? a rac man told me it was called a smart charge but i have been to ford and they dont no wat im going on about, is this the same thing as your saying if so how do you fix the problem??
thanks

In Topic: battery light

27 April 2009 - 12:10 PM

;) have you cleared the fault code

yeah ive cleared the fault code and its now just the battery light staying on when the car is running, the lights are also all flickering when its running any more ideas??
thanks