Jump to content


5t3v3

Member Since 12 Jun 2009
Online Last Active Today, 12:03 PM
-----

Topics I've Started

Mk7.5 Steering Wheel Trim Removal.

01 May 2015 - 07:42 PM

Hi folks, trying to remove the metal trim from the steering wheel on my 2014 st so that I can wrap it gloss black, any ideas how to remove it? I've undone the three screws at the back of the wheel. The top two came out ok, bottom one is loose but won't come all the way out, think I'll need to wedge a flat screwdriver under it while I turn it with the torx key. The cruise control and audio controls seem to be attached to it as well any ideas what I need to do next?

Thanks
Steve

Needing A Service Already?

12 January 2015 - 01:25 PM

So i fitted an Auto Specialists Stage 2 induction kit and a bluefin remap on friday night drove the car around all weekend and all was good, better than good. However on my way to work this morning the little spanner popped up on the dash and a message on the screen came up saying "Service Engine Now". Surely not though, the car hasnt even done 5k yet.

 

Anyone got any ideas if its something i've fitted or if it genuinely needs a service?

 

Thanks 

Steve


St Is Getting More Power Next Week!!

01 January 2015 - 05:41 PM

As the subject states, ive got the bluefin remap and the auto specialists stage 2 induction kit ordered today So hopefully they will arrive towards the start of the week. Cant wait for all the extra torques and horsepowers!!!!!

St 180 Induction Kit.

17 December 2014 - 09:59 PM

Evening folks, can anyone recommend a decent induction kit that doesn't cost ridiculous amounts of money? Had a look at the Auto Specialist ones and really grudge £200 for it.

Thanks

Steve

Mk 7.5 St Usb Trouble

30 November 2014 - 01:04 PM

Hi folks, anyone else having trouble le using the usb port when something is plugged into the 12v socket? My iPod works fine until I plug my phone in to charge in the 12v socket, pretty much as soon as it's plugged in as well the usb connection keeps getting dropped every few seconds, sometimes minutes and ive got to take the iPod out then connect it again to get it working for the next few mins. Take the phone back off charge and it goes back to working fine. Also does anyone know if there is away to get the software updates without having to go to ford?

Thanks
Steve