Jump to content


Show

Cooky

Member Since 06 May 2008
Offline Last Active Dec 24 2009 05:33 PM
-----

Topics I've Started

04 mondeo wiring problem

17 December 2009 - 05:13 PM

Just had the car to the garage and they diagnosed a wiring problem from the EGR

anyone know of this problem when you start the car all is fine then you rev it and the coil light flashes and the car is really sluggish wont go over 30mph at first but builds upto around 50mph after a while

any ideas what wire it could be or what fault


thanx

ADMIN

15 December 2009 - 08:43 PM

could you change the settings so you can search words 3 letters long ???


searching EGR you cant as its to short :rolleyes:

glow light flashing

15 December 2009 - 03:34 PM

My 04 mondeo has just lost power and the glow light is constantly flashing i can get about 50mph in 4th but pulling away is really sluggish


any ideas guys


thanx

doors leaking on a mondeo

22 November 2009 - 06:30 PM

The back and front doors are leaking on ym 04 plate mondeo

the water is running down and in through the rubbers that are on the cars body not the doors

carcraft messed about with them as there was a whistling sound and then when we went back they said it wasnt their fault GRRR

any ideas ???

cheers

Mondeo losing power

14 August 2009 - 12:21 PM

My 04 plate mondeo tdci ghia has seamed to lose power, we had a service done yesterday oil,air filter etc but its still kicking out black smoke quite a bit at times and when your driving along its as if the your pumping the accelerator peddle slightly as the car seems to rock

any ideas guys ??