Jump to content


paramaniac

Member Since 19 Sep 2009
Offline Last Active Aug 01 2013 07:59 AM
-----

Posts I've Made

In Topic: 2009 1.8 Petrol - How Much Oil For Service?

11 January 2013 - 11:38 AM

Ah ok, I'll check.

In Topic: Focus 1.8 Zetec "squeak" On Cold Startup

02 July 2012 - 05:59 PM

Duncan, did they replace the belt and the tensioner or just the belt?

When they diagnosed mine the car was still under warranty and Benfield Ford (Harrogate) tried the "wear and tear" trick on me. But if you look at the Ford service schedule for the 1.8 petrol, the aux belt is not supposed to be replaced until 100,000 miles. So for it to become faulty at 2 1/2 years old and 25,000 miles, there's obviously an issue or crap parts. I pointed this out to them and they replaced the belt and tensioner under warranty.

In Topic: Focus 1.8 Zetec "squeak" On Cold Startup

01 July 2012 - 03:59 PM

I had a similar issue, fixed by replacing the auxillary belt and tensioner.

In Topic: Focus Zetec 1.8 Petrol Tickover High And Rising

31 May 2012 - 03:29 PM

I had this issue with my car (see info on left). It turned out to be a faulty auxiliary belt tensioner which needed replacing along with the belt.

In Topic: 2009 Focus Zetec S

25 May 2012 - 02:35 PM

Yeah might consider getting some non-genuine ST 18" alloys if Lewism won't give his up :)

The alloy spokes on that red ZS look thinner than the genuine RS alloys. Personally I hate black alloys! I like what he's done with the exhaust though, I want to do the same but on one side only.