esmeella

2004 KA temp light on and off when heating used, car not overheating!

Recommended Posts

Hi,

new to forum , hoping someone can help. Have had this car for a few weeks, 2004 Ka. On 3 occasions the temp light has come on but gone off again. On all occasions I have had the car sat at work from 5-10pm and it has happened when I have gone to drive home. On all occasions I have put the heating straight on when driving off, within 5-10 mins the light has come on but gone off again (not sure if it goes off when heating turned off). Note- heating working fine and once light gone off if heating put back on the light doesn't come back on. Seems to just be when driving off after car has been sat and heating straight on.

I am 100% sure the car is not overheating, it is driving perfectly and the light always goes off after a few mins. The coolant is at max and has not leaked, the fan is kicking in as expected and the bonnet is never hot. Although this isn't a major problem and more of an irritation it is annoying to have the temp light come on when driving as it worries you the car will over heat! My dad is good with cars but on holiday at the moment, he is back next week and I am hoping someone could give me some advice as to what we could check. I wondered if it could perhaps be a loose connection for the temp sensor or a sensor to do with the heating?

 

Apologises for the long post, I hope it makes sense! :)

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now