Sign in to follow this  
Alexkey33

Car won’t start

Recommended Posts

My 2011 Ford Fiesta zetec s TCDI won’t start, started chuddeding as I was driving and hasn’t started since. Code reader is showing no codes and easy start doesn’t work. New battery has also been tried and still no luck

Share this post


Link to post
Share on other sites

Does the car run on the easy start then stop when it has burned it or is there nothing at all?

Share this post


Link to post
Share on other sites

Are you spraying the easy start then trying to start it or is there some one spraying why someone is trying to start it ?

Share this post


Link to post
Share on other sites

If it won't run on easy start it's likely to be a mechanical issue, diesels only need a bit of compression to go with easy start unless you're not using enough lol.

Does it sound like it's got compression when you turn it on the starter?  

Share this post


Link to post
Share on other sites

Use a lot..doesn’t seem to be turning over fast enough and I’m thinking a compression problem 

Share this post


Link to post
Share on other sites

a compression problem is normally lower compression than it should have which would mean the starter motor would turn the engine faster then it would normally do, not slower. I can't really see how the compression could get higher. 

When was the fuel filter last changed?

What sort of code reader are you using?

have you checked the cam shaft is turning with the engine (ie. checked it is not broken cam / timing belt)

Share this post


Link to post
Share on other sites

Not a clue when the fuel filter was last changed only had the car just over a year but when you turn the ignition on you can hear it power up.

code reader was a snap on solus pro.

Is that a costly repair?

Share this post


Link to post
Share on other sites

we can't say if it's costly or not.

if it's a blocked fuel filter then it's not costly.

if it's a broken cam belt/timing belt then it can be very costly due to the valve damage that occurs when belt breaks.

but we don't know if it's either of those things.

I don't think anyone is going to be able to diagnose this on this forum. It needs someone to see it in person and check things.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this