paulo66

active grille shutter problem

Recommended Posts

hi all looking for help with this issue, i have a 60 plate Mondeo TDCI 140 Zetec (facelift) mk4.5
Engine malfunction light came on - diagnosed U0204 "Lost communication with active grille air shutter module a pending DTC"  grille shutters open and intact. checked wiring and no obvious signs of corrosion on plug or motor connection. 
shutters move freely and can be shut then open when ignition is on.

am at a loss as to what to do

Share this post


Link to post
Share on other sites
 

anybody help out there please

Share this post


Link to post
Share on other sites

is there anyone who can help at all?

Share this post


Link to post
Share on other sites
On ‎1‎/‎3‎/‎2019 at 2:20 PM, paulo66 said:

shutters move freely and can be shut then open when ignition is on.

So are the shutters working fine or do they just default to open if you manually close them before switching the ignition on? 

Does the code come back once cleared?

 

Share this post


Link to post
Share on other sites

hi yes shutters default to open when closed manually so assumed the motor is working, the code comes back everytime after clearing.

have checked the wiring and no signs of corrosion on either end.

 

Share this post


Link to post
Share on other sites

Ah ok, yes it sounds like the shutters work but aren't getting any info from the PCM.  Have you tested the wiring with a multimeter or just visually looked for corrosion?  That'll be the next thing to try if not done already.

Share this post


Link to post
Share on other sites

GW

Hi mate
Disconnect the grill engine plag, delete all warnings with the scanner, and then, start the engine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now