Honkqvist92

Ford Fiesta car battery/alternator problems! Help needed!

Recommended Posts

Help needed with a Ford Fiesta 1.0 2012!

The battery warning light comes on every now and then, i have changed the car battery recently to a Bosch S5 and i have measured the battery voltage while the car is running and and the alternator seems allright.
The other night when my girlfriend was driving the car everything went all black, all lights got shut but the car was still running...Radio died aswell!
She described the steering wheel as very stiff and hard to turn around, she parked the car and phoned me.
A few moments later the car worked normally again and she drove it home, weird ***** indeed!
Im wondering if anyone has experienced something similar and could give advice on what to do! 

Thanks in advance!

 

Share this post


Link to post
Share on other sites
 

Are the battery terminals and connectors all ok? maybe corrosion on the battery cable connectors?

Share this post


Link to post
Share on other sites

Your Mrs has never driven an banger from the 80's! The stiff steering you speak of is what happens when there's no power steering. It's great up at speed, but really hard trying to park 😂😂.

I'd maybe clean the battery terminals and wires (use some emery paper or scotch brite if you have any) then reapply a smear of grease to prevent corrosion.

Share this post


Link to post
Share on other sites

Well in fact she hasnt! But she describes the steering as getting stiff while the car was running, as if the drive belt stopped working! Is it even possible?
Anyways, ill check out the terminals and wiring! 

Share this post


Link to post
Share on other sites

It's electric steering, so isn't powered off the belt, meaning yes it is possible.

Did you change the battery because of all this? Or has the faults only started since? Also which Bosch S5 did you install?

Share this post


Link to post
Share on other sites

Have to check out which one it is later, i changed it a few months ago when the battery warning light came on.
These more serious problems appeared after changing battery!
Today i cleaned the battery terminals and connectors and everything and it worked but the problem doesnt occur constantly so we'll see. :)

Share this post


Link to post
Share on other sites
On 1/13/2019 at 2:43 PM, Honkqvist92 said:

Have to check out which one it is later, i changed it a few months ago when the battery warning light came on.
These more serious problems appeared after changing battery!
Today i cleaned the battery terminals and connectors and everything and it worked but the problem doesnt occur constantly so we'll see. 🙂

Measure the voltage at the battery, really this procedure should be followed on a fully charged battery when fitting it to the car for the first time.

 

battery should read 12.6 - 12.7v when fully charged.

 

Reset BMS 

 

Turn ignition to ON but do not start the car

Press hazard light switch 5 times

Press rear fog lamp switch 5 times

Watch for battery light in IPC to flash, once it's stopped flashing turn off ignition and open drivers door.

Close drivers door and ign on, start engine

Procedure complete

 

Its worth a try if you're still having issues 

Edited by M6 44t car park attendant
Missed a bit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now