Recommended Posts

I have just had my Ford Mondeo 1.8 Lynx engine fitted with new timing belts the top one and the lower wet belt plus new pulleys and tensioners fetched it yesterday problem is the engine management light has come on any ideas why,will be taking it back to the garage on Monday.Forgot to say New water pump as well.

Share this post


Link to post
Share on other sites
 

take it back let them sort it and see if there's any logged code on it

Share this post


Link to post
Share on other sites

Took it in, it was a split vacuum pipe whatever that is anyway management light not on now. Just hope it stays that way.

Share this post


Link to post
Share on other sites

Well all was well guess what the engine malfunction came on again this time it threw up code P1204-00 and P0691-00 got a horrible feeling it needs an injector  replacing.I asked him could this be because of them fitting the two timing belts he says not any opinion welcome.😕

Share this post


Link to post
Share on other sites

Replaced one injector engine running smoothly no engine  malfunction coming on.😅

Share this post


Link to post
Share on other sites
7 minutes ago, Martin53 said:

Replaced one injector engine running smoothly no engine  malfunction coming on.😅

happy days :smile:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.