Glennington

Understanding Mk7 Stereo Connections and upgrade help

Recommended Posts

Hi all,

I know there are alot of discussions about upgrading fiesta stereos to the Sony model but I would also like to ask. My Fiesta is a mk7 1.25 Zetec 61 reg (first registered January 2012)

I would like to replace my stereo (see picture) AA6T-18C815-GB (Silver fascia stereo with bluetooth and voice control) (and red matrix display) with a Sony Fiesta stereo (E1BT-18C815-HK) (see picture) (with colour LCD display)

I will be replacing the fascia, head unit (silver box) and the display.

Will this be a matter of plug and play? Will I have to change a few parameters in the central configuration using Forscan? Will my SYNC module work (or is just called a bluetooth voice control module ( is it pre-SYNC days?)) (see picture attached of my current module)?

I have also found that my original stereo has the exact same connections as the Sony one. However one of the sockets is not used (the large one next to the black and white connectors) (I do not seem to have the plug for that in my wiring loom)

Could someone also tell me what each of the connections are for? I've been trying to find information about this but with no luck. - There seems to be alot of variations of connections in the mk7 stereos.

P.S. I also found a redundant plug behind my glovebox - the red connector (see pictures) - does anyone know what this is for?

See pictures here: https://imgur.com/a/h37sG70 (Sorry, upload limit here is 2mb, not enough for my camera pics)

 

 

Share this post


Link to post
Share on other sites
 

If anyone could point me in the right direction for mk7 stereo connection info, that would be great!

Share this post


Link to post
Share on other sites

Hi there. Looks like you already have the DAB head unit? The fascia and screen should just be plug and play regardless. As for your mystery connections the black and white are FM/DAB connectors whilst the socket next to them is for sync as far as i'm aware.

Share this post


Link to post
Share on other sites

I think you’ll need a new Sync module to get full function. Get one that’s Sync 1.1 compatible so you can get track names through bluetooth. Modules D1BT or newer. 

Share this post


Link to post
Share on other sites

Thanks for the reply guys

My unit already displays track names over bluetooth...

6 hours ago, craigh33 said:

Hi there. Looks like you already have the DAB head unit? The fascia and screen should just be plug and play regardless. As for your mystery connections the black and white are FM/DAB connectors whilst the socket next to them is for sync as far as i'm aware.

Which one is the DAB connector? (the white one?) Does this mean I already have a DAB antenna? Do you reckon the module I have is not a SYNC module?

Share this post


Link to post
Share on other sites

Cant be sure if there is nothing plugged in but the head unit is capable as it has both fm (black) and dab (white) connectors.

The module you have is one of the early bluetooth modules that is not sync capable. The late ones look like this.

Share this post


Link to post
Share on other sites

Hi Craig,

Oh I see, guess I can get a SYNC 1.1 for around 30 quid.

I forgot to mention, I do have a white connector plug (it was plugged in to the back of the head unit).. bit weird since my stereo does not give me the option to access DAB.

Share this post


Link to post
Share on other sites

Hi all,

The new unit came today and I have just installed. Unfortunately the LCD did not arrive... I have contacted seller, waiting for response.

It seems the as soon as I turn the stereo on with or without ignition, the display is stuck at the splash screen, the stereo will not do anything no sound etc.

I still have the option to go to menu settings for vehicle, clock, display and messages, just no stereo..

I have tried disconnecting the battery, waiting a few minutes and reconnecting but nothing...

Also tried pulling out no. 21 fuse and reinstalling but still nothing... (I have the type 1 fuse box) https://www.autogenius.info/ford-fiesta-mk6-2008-2017-fuse-box-diagram/

Any ideas? Perhaps I need a SYNC 1.1 module? Or do I need to do some configuration on Forscan?

2019-02-12 20.01.29.jpg

Share this post


Link to post
Share on other sites

Pretty sure you need to change a setting using Forscan. 

Share this post


Link to post
Share on other sites

Ok, once my ELM327 lead comes I will update a setting in the Central Configuration - if I can find the relevant parameter.

However, I have just tried using the new LCD. Similar to what is shown in pic below.

Image result for stereo fiesta lcd

It seems if I install the new LCD in my old head unit then the stereo doesn't even turn on!

If I install the old LCD in the new head unit I get a frozen screen (as described above).

If I install the new LCD in the new head unit, the stereo turns on (I can hear it) (AUX does not work though, the button doesn't do anything, possibly because of incompatible SYNC module with head unit) but no display! - LCD does not turn on at all.

Do you think the reason for no display on the LCD is only due to the configuration set in the BCM i.e. I've just gotta change a setting using Forscan?

 

 

Share this post


Link to post
Share on other sites

On 2/15/2019 at 9:32 PM, Glennington said:

Ok, once my ELM327 lead comes I will update a setting in the Central Configuration - if I can find the relevant parameter.

However, I have just tried using the new LCD. Similar to what is shown in pic below.

Image result for stereo fiesta lcd

It seems if I install the new LCD in my old head unit then the stereo doesn't even turn on!

If I install the old LCD in the new head unit I get a frozen screen (as described above).

If I install the new LCD in the new head unit, the stereo turns on (I can hear it) (AUX does not work though, the button doesn't do anything, possibly because of incompatible SYNC module with head unit) but no display! - LCD does not turn on at all.

Do you think the reason for no display on the LCD is only due to the configuration set in the BCM i.e. I've just gotta change a setting using Forscan?

 

 

Hi there, any luck getting this to work?

Share this post


Link to post
Share on other sites
8 hours ago, M.Thompson said:

Hi there, any luck getting this to work?

Hi Matt,

I've received the ELM327 USB adapter and have got to the Central Configuration (main) window.

I will probably play around with installing the new Sony head unit this weekend.

I'm still not certain what parameter I need to alter in the central configuration though. I have attached a print screen of the two parameters that I probably need to change but I would like to get some clarification.. if anyone knows?

Is it (with Sony Head unit installed):

Digital Radio Receiver: Value 02 - DAB Radio System with PTY EU and ROW

In Car Entertainment: Value 14 - High level CD and AM/FM Radio Branded

?

 

 

1093443592_ForscanCentralConfig(main)5.thumb.png.eba069ac6ffaab4e987a0aa40828f6e0.png

 

732762529_ForscanCentralConfig(main)4.thumb.png.83f9bef0215ea4dfe8a86b9615134223.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now