BugCo22

Strange noise - fixed

Recommended Posts

Ok sorry if the title is a bit vague. I currently own a 57 s max. Bought it cheap and came with a few problems, slowly working my way through them. But today I replaced my suspected faulty EGR valve. Only with a cheap used one to see if it made a difference. But on a test run, the engine is making a kind of "parade whistle" (warble whistle) noise that seems to follow the boost and vacuum stages of the engine running ?? It's quite loud from the outside. I will post a short vid tomorrow of the noise. I'm not sure if the original EGR was fooked and fitting this one has revealed a leak else where ?? It's just the type of noise is really odd. I've done all sorts of internet searches and nothing comes close to the noise I'm getting. I was just wondering if anyone had any ideas ?? Ok it should be this link, the last one was my daughter at Christmas:-/  https://drive.google.com/file/d/1sj7h9u21aoD3Cmg4fLT6vGAXzotnINN6/view?usp=drivesdk

 

Share this post


Link to post
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.