Sparky6911

Lumpy idle when warm

Recommended Posts

Evening All,
 
1st post so be gentle with me.
 
We have had a 2006 C-Max with the 1.8 duratorq engine for a couple of years and it's been a great family car.
 
Recently when the engine is hot the idle causes the whole car to rock/shake, so much so it actually make the car an unpleasant place to be (freaks out son out).
 
Car has just had a full service to see if that could help, the garage added a fuel system cleaner to see if that would help, no change.
I've also cleaned the EGR valve and associated mechanism with one change.
 
So I was wondering if anyone has any ideas what could be causing this? Could it be something as simple as a worn out engine mount or something more serious?

In normal driving the car drives well and pulls strongly which is what's so confusing.
 
Thanks in advance,
 
David
 
Sent from my Mi MIX 3 using Tapatalk
 
 


Share this post


Link to post
Share on other sites
 

Is it a misfire type lumpiness or is it just the engine rocking if thelater then it could be an engine mount, your garage doesnt sound very helpful.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.