WoldsWarrior

Mk7 ZS 1600 petrol Hesitations

Recommended Posts

Morning!

Ive recently bought a 2009 Zetec S 1600 petrol, with 52k on the clock, and im just working my way through a few faults.

Recently done the Bonnet Catch and Boot Latch, sorting two issues out straight away.

I have noticed when driving along at a speed, say 60, that the slightest touch of the throttle causes the car to feel like small judder but isnt actually a judder.

Would this maybe be a coil pack issue?

Its hard to describe, more like a small jerking feel.

Its getting the Rear Axle Bushes done on Thursday and a full service, inc Cambelt Kit and Water Pump, so im hoping it just needs a refresh.

Thanks

 

 

IMG_0543.jpeg

Share this post


Link to post
Share on other sites
 

My fiesta 1.4 p doing same, i had my gearbox, clutch and mounts replaced (for another problem) and i still have same problem, i think can be coil pack, o2 sensor or vacum leak

Share this post


Link to post
Share on other sites

Replaced Coil pack and leads, and Plugs, and still there.

Im wondering if its the engine mounts now in all honesty.

Common thing?

Share this post


Link to post
Share on other sites

Have you scanned for any codes? Give the MAF a spray?

Share this post


Link to post
Share on other sites

5 hours ago, wild_one said:

Have you scanned for any codes? Give the MAF a spray?

To be fair, no, i haven't, ill get my mate who's a self employed ex Ford tech to have a scan for me.

Is the MAF on the air intake off the airbox on these?

 

Share this post


Link to post
Share on other sites

You can scan it yourself:

Ford Fiesta MK7 hidden menu procedure

  1. Press and hold trip reset button on the instrument cluster.
  2. Turn ignition on with key or by pressing START button without clutch. After few seconds “test” message will appear on the display.
  3. Release the button.
  4. Browse the Ford Fiesta MK7 hidden menu with trip reset button.

 

Share this post


Link to post
Share on other sites
6 hours ago, WoldsWarrior said:

To be fair, no, i haven't, ill get my mate who's a self employed ex Ford tech to have a scan for me.

Is the MAF on the air intake off the airbox on these?

 

Yes, you'll see it near the airbox with a multi connector. Two little torx screws to remove it. Tread lightly they are fragile, and do not be tempted to touch the wires. Only use MAF spray or alcohol. Nothing to lose by cleaning it.

Share this post


Link to post
Share on other sites
11 hours ago, wild_one said:

Yes, you'll see it near the airbox with a multi connector. Two little torx screws to remove it. Tread lightly they are fragile, and do not be tempted to touch the wires. Only use MAF spray or alcohol. Nothing to lose by cleaning it.

Yeah i thought that was it.

Used to sell loads when i worked for a Vauxhall Dealer back in the early 2000's!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.