JPryer123

MK3 Parking Aid Module

Recommended Posts

I've recently had a fault come up on the Parking aid module where it says park pilot malfunction and on rearing the dtcs it shows rear left sensor internal component failure, so I changed the sensor with a new one from Ford, the fault still exists... so I did some further diagnostics and when walking round my cat all the distances stay at 3m. So I'm guessing it's the module that's faulty but I cant find it for the life of me has anyone had anything similar? 

Screenshot_20190806-094914_FORScan Lite.jpg

Share this post


Link to post
Share on other sites

You can’t find the module ? 

Its behind the carpet trim in the boot right hand side 

Share this post


Link to post
Share on other sites
1 hour ago, Tommo17 said:

You can’t find the module ? 

Its behind the carpet trim in the boot right hand side 

Is that for the front and rear sensors? 

Share this post


Link to post
Share on other sites
22 hours ago, JPryer123 said:

Is that for the front and rear sensors? 

Yes if you have factory fitted front and rear it’s the same module for both

Share this post


Link to post
Share on other sites

I would be checking the wiring to the affected sensor. If a sensor or wiring fault occurs it disables the whole system. That's why it shows 3m on all sensors. Wiring corrosion is common. I would unplug the wiring from all rear sensors and the multiplug. Unclip the wiring and have a good look off the vehicle. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.