King Mustard

Head unit doesn't show Android Auto when phone plugged in

Recommended Posts

I've had my 2019 EcoSport for five days.

The first four days, each time I plugged my phone (Huawei P30 Pro) in, Android Auto appeared in the navigation bar on the head unit (car stereo) and everything worked great.

However today, nothing.

Tried both USB ports, two cables, restarting the phone, turning the car on/off etc.

The phone starts charging and Android Auto auto-launches on the phone itself but the head unit doesn't show the Android Auto tab along the bottom.

The head unit connects to the phone's bluetooth every time without issues.

The phone is running Android 9.0 and I'm using the latest Android Auto app and head unit software etc.

Any ideas?

EDIT: It appears MTP/Media Transfer Protocol was disabled on the phone and was set to Charging Only. I have no idea what changed that since my drive this morning (when Android Auto last worked fine) - I certainly didn't.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.