Sign in to follow this  
Kentranger

2008 Ranger Hazard Light fault

Recommended Posts

Evening all.

I have a 2008 (58) plate ranger. I noticed the other day my hazards are not working. The switch itself Doesn't flash when switched on and the tell tales on the instruments do not flash. 
 

just wondering if anyone has had this issue or could point me in the right direction.

ta 

Share this post


Link to post
Share on other sites

No was going to do that first in the daylight. Just wondered if there is a common problem. Any ideas which fuses it is. I’ve miss placed my handbook? 

Share this post


Link to post
Share on other sites

F the left and right indicators work off the stalk ok, the fuses will be fine. Sounds like the hazard switch is faulty. 

Share this post


Link to post
Share on other sites
36 minutes ago, iantt said:

F the left and right indicators work off the stalk ok, the fuses will be fine. Sounds like the hazard switch is faulty. 

I did wonder that. But am I right in saying it has to go through a hazard flasher unit? Or is this incorrect? Thanks 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this