Sign in to follow this  
richard66

Cruise control not working on my Ford Focus Mark 2.5

Recommended Posts

Hi everyone I bought a Ford Focus Mark 2 facelift about 3 years ago go I have never had the cruise control working on it as it doesn't seem to work I know the buttons on the steering wheel work any advice on what's wrong with the cruise control

Share this post


Link to post
Share on other sites

What seems to not work?  If you use the button on steering wheel do you see the green sign on the dash cluster?

 

Share this post


Link to post
Share on other sites

Not sure on Fords but Brake sensor on Vauxhall’s is fairly cheap to fix. 

Share this post


Link to post
Share on other sites

Definitely setting it correctly?  It's a bit odd on these as you have to switch it on before being able to set the speed...but nothing happens when you switch it on (no lights etc) so it's not obvious until you set the speed as well.

If it's not holding a speed, chances are either the clutch or brake switches are faulty.  If you've got Forscan you can test their function, if not you can manually test them with a multimeter, they are just simple on/off switches.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this