Jump to content
Do Not Sell My Personal Information


Hmm heated front screen. Fuses didn't fix it?


Recommended Posts

Afternoon guys 🙂

I hope y'all ok, been a while since I was last in here.

OK so firstly, it's cold 🥶 and I haven't had my front heated screen working ever since I think it fried my alternator.

But today I was like, enough already, I can't cope with -3.0° in a morning anymore so I need it working again.

I had a look in the fuse box under the bonnet and saw this:

So according to the haynes manual I had one missing, I must have taken one out last time when I had alternator issues.

So I went to Halfords and picked myself up 2 new 40 amp fuses.

First thing I noticed is there is only one pin showing on the left hand fuse, this can't be right surely, can it?

Then I noticed further down the fuse box another place for a fuse also had only one pin in it, so maybe it is?

Can someone confirm firstly if that is right, the right hand fuse has 2 pins but the left hand only one? *confused*

Anyway I banged these in and ... nothing. The light comes on when I press the button for the heated screen but I don't hear the... * click * that I used to hear and it's not having it.

So what is responsible for the click, is it a switch or a relay? I can't find any info on it in the manual.

What would you guys be checking next after replacing these two 40amp fuses? And if there is a relay does anyone know where to buy them and where they are located and I'll get on it.

Keeping um crossed it's an easy fix and I will only use it sparingly and I'll scrape windows first and keep some revs on when I do fire it on and take it for a good drive after because I hear that using the heated front screen is a battery killer.

Thanks in advance fellas 🙂

1.thumb.jpg.c61991d0c47eaf85e97e066716c92cac.jpg

Link to post
Share on other sites

Oops I installed them wrong haha 😊

This is the fuses in the right place.

2.thumb.jpg.df155f75def4195706a1e63bbe0c6c68.jpg

However, no joy, the light comes on the front heated screen button on the dash but no 'Click!'

I tried the rear, that works and the click which I am guessing is a relay, well the sound is coming from the passenger footwell.

Am I right in assuming that the relay is the fault and that is also located in the passenger footwell?

Again if anyone knows of a link or a part number and location, would help me out no end.

Thanks in advance 🙂

Link to post
Share on other sites

I think so Tom.

I am fathoming it bit by bit.

snap540.thumb.jpg.7d73e9cd1ce79482a0b08ac5b043bca8.jpg

I think the relay is R7 under the bonnet, I have pulled mine out, I rang Ford they want £48 for it.

Found it here for £7.98 - https://www.citycarparts.co.uk/land-rover-ford-multi-use-grey-relay-12v-70a-fomoco-5m5t-14b192-ea-has-4-pins-14219-p.asp

But I would prefer a more reputable brand, not sure if this one fits: https://www.buycarparts.co.uk/hella/13668602

Nor am I sure if the one I pulled out my car was original, it's branded FOMOCO.

I don't think Halfords do them so I guess I will have to order one online. If this doesn't fix it I ain't sure what else is left to try. It used to work fine until my alternator packed in, then I was pressing it one day and the clicks just stopped clicking lol so I am thinking it has to be this relay.

My battery is overkill for this car, cost me like £110 when I bought it, then again it's about 5 years old now.

Link to post
Share on other sites

FoMoCo is Ford Motor Company so that will be original.

Are either of the other 2 grey ones the same?  If so, swap one with the heated screen...screen should work, other item should not...  Quick free test!

The battery could just be low from little use btw, not suggesting the battery itself isn't up to the job.

Link to post
Share on other sites

That's a cracking idea! I've checked and one has a diff number stamped on it so I best not risk it, but it would never have occurred to me to try lol something as simple as that, thanks for the tip I'll try and remember it for next time.

Also didn't know what FoMoCo stood for, in that case if it's original Ford I'll get one of those ordered online and save myself £40 than going to a Ford dealer lol.

Thanks a lot! I'll report if the relay and fuses did the job 🙂

Link to post
Share on other sites

Morning guys.

So I purchased one of those FoMoCo relays second hand from Evilbay, mine rattles when you shake it, the new one doesn't.

Anyway I popped it in the car, fired her up, gave it some gas at idle, hit the fronted heated screen button and... nothing, still no 'click' like I get when I click the rear heated screen button.

I am hearing the click in the passenger footwell for the rear but the main relay for the front is in the main fusebox under the bonnet, that being said I still used to hear a click when I hit the switch.

So with that R7 relay replaced and no joy, what would be the next logical thing to check? Is there anything in the passenger footwell that relates to the front heated screen.

Stuck now *sobs* if anyone has any info be very much appreciated.

Thanks in advance 🙂

Link to post
Share on other sites

Ah good idea. OK so ... hmm I have a multimeter, is it a case of getting someone to press the button on the dash and me use the multimeter to see if I get any current when putting the multimeter prong in the ports?

Link to post
Share on other sites

3 minutes ago, ThePowster said:

Ah good idea. OK so ... hmm I have a multimeter, is it a case of getting someone to press the button on the dash and me use the multimeter to see if I get any current when putting the multimeter prong in the ports?

You can do it on your own.  Pull the relay.  Switch the engine and heated screen on.  Then touch one probe to any earth and the other to the relay connector pins in turn.  Test for DC voltage, one pin should be live with the screen switched on.  (You can work it out from the relay diagram, but it's probably quicker just to poke them all lol)

  

 

Link to post
Share on other sites
22 hours ago, TomsFocus said:

Test for DC voltage, one pin should be live with the screen switched on

Two pins should be live with the screen switched on, one for the relay coil and the other for the screen supply contact.

Link to post
Share on other sites

My whole heater unit stopped working. I disconnected the battery for ten mins, reconnected and it worked. 

Just saying. . Switch it off and switch it on again sometimes works. 

Link to post
Share on other sites

Thanks John. I have tried that mate before and no joy this time unfortunately.

So I have been out today with the multimeter and this was my findings:

4 female contact points which accept the relay starting clockwise at the top, 1-4 ports.

Key: 1 - Top. 2 - Right. 3 - Bottom. 4 - Left.

 

No ignition

1. 0.00v

2. -0.00v

3. -0.00v

4. 0.89v depleting rapidly

 

Ignition on 

1. 0.89v depleting rapidly

2. -0.02v

3. 1.06v depleting rapidly

4. 1.01v depleting rapidly

 

Front screen button pressed 

1. 0.02v

2. 0.02v

3. 1.01v depleting rapidly

4. 0.90v depleting rapidly

 

1.thumb.jpg.6575b9bb349752fa456674085e21a8ad.jpg

Pic above shows how multimeter was set. Initially I had the red wire of the multimeter in the far left hand port of the multimeter where it says 10ADC and the black one to the right hand side next to it. I wasn't getting any readings so I fetched a AA battery and got it plugged in above which is correct and showed 1.5v of a AA bat so I knew it was right then.

2.thumb.jpg.035b656da490a229de303269218b08a6.jpg

Above is where I had the negative clip of the negative terminal for the multimeter on this bracket.

3.thumb.jpg.1dd93a638c372fd3a50444c539f4ea5e.jpg

Image above shows how I did it to begin with, straight from the negative terminal and I got a spark on far left 4 female connector when I put the red multimeter point on it, not sure if this means anything or not.

So... Where do we go from here?

This R7 relay is in the main engine fuse box as are the two other fuses which have all been replaced, still no 'click' when I hit the button on the dash like I hear from the button when I hit the rear screen demister thing.

Is there any more relays and fuses relating to the switch in the car which does light up but nothings happening, from there to make the front heated screen come on.

The last time it worked was when my alternator packed in. I replaced it and it's not worked since. It was like something perhaps blew before my alternator packed in, I remember pressing the button, click, on .. click yep worked again, and during that day I pressed it, no more click, no more heated screen *sobs*.

 

Link to post
Share on other sites

When you got the spark with the meter connected up to measure amps rather than volts you probably blew a fuse in the car and possibly also one in the meter, all readings after that are suspect until the blown fuses are replaced.

Link to post
Share on other sites

Oops... 

As above, may have popped the fuse.  You were right first time with the neg location, unpainted metal gives less resistance for a more accurate reading. 

While you've got the fuse out, I'd also check for 12v reaching the fuse connector.

Link to post
Share on other sites

As Tom says, you need to make sure you connect the negative lead to unpainted metal. That bracket you used is painted and won't give a good contact. The tag at the end of the battery earth lead at the top of your photo would give a more reliable connection. When you clip it on hold it shut and give it a wiggle to break through any oxidation.

Those voltage readings look very abnormal. I would not expect to see a declining voltage. That's what you'd get from a discharging capacitor and there shouldn't be anything like that in the circuit. As Paul has said you may have blown a fuse in your meter or even caused damage to it by using the 10A current input but you can easily check that. With your negative lead clipped to the battery earth point can you read voltage (around 12V) on the battery positive post? I have a feeling that only the current ranges are usually fused anyway so it should still work on voltage.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership