Jump to content
Do Not Sell My Personal Information


Ford Mondeo Mk4 (2011) weird headlight failure and general problems


Recommended Posts

Hi all!

First of all excuse my English. I'm from the Netherlands. I have an issue with my 2011 Ford Mondeo Station Diesel. A few weeks ago one of the headlights failed me. After changing the bulb, no dice. But the problems get weirder. Some nights the little parking lights (or one of them) will stay on. This might be for a few hours, or a few minutes. Also, the other headlight has now also failed, but will sometimes begin to work at random. This goes along with the car not responding to the key, but being fully functional once you turn the key in the door.

I'm at a complete loss as to what could cause this. The car seems to have a mind of its own, and there's nothing I can do to help it. Are there any amongst you that have experienced the same issues? Is this just a complete wiring failure?

Thanks for any responses! I really hope to be able to fix this car!

Bram

Link to post
Share on other sites

Is the car being used regularly? Just wondering if it could be a faulty battery as they can cause weird things to happen.

I replaced the battery in my car after it started to fail, I had strange problems with the temperature control  where I turn the knob and it would normally stop at 'max' but it went back to 'min' and started to scroll though the temps. Also one of the xenon lights would flash off and on again.

Link to post
Share on other sites
16 hours ago, Frembrit said:

Is the car being used regularly? Just wondering if it could be a faulty battery as they can cause weird things to happen.

I replaced the battery in my car after it started to fail, I had strange problems with the temperature control  where I turn the knob and it would normally stop at 'max' but it went back to 'min' and started to scroll though the temps. Also one of the xenon lights would flash off and on again.

Yes, the car is being used every day! Although we did have a low battery sign in the car a few weeks back. We trickle charged the battery after that (the problems had already started, so trickle charging isnt the cause) and the message didn't come back after that. Also the battery isn't even 4 years old yet. But it might be worth replacing it then!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership