Jump to content
Do Not Sell My Personal Information


Recommended Posts

Hi, my mk3 focus titanium x is having intermittent issues. Firstly, it sometimes won't start with no dashboard lights as though it has no power. After 10 mins it starts first push of the button. Secondly, it sometimes displays ' hill start assist' and 'active city stop' not available. are these issues related and what's the fix?

Link to post
Share on other sites
2 hours ago, dikijohn said:

Hi, my mk3 focus titanium x is having intermittent issues. Firstly, it sometimes won't start with no dashboard lights as though it has no power. After 10 mins it starts first push of the button. Secondly, it sometimes displays ' hill start assist' and 'active city stop' not available. are these issues related and what's the fix?

Good evening dikijohn!

In my opinion you will have to check out your battery's voltage first.

If your battery is healthy you must enter a diagnose tool to the OBD slot in order to check further for ecu faults.

But i think that there is a battery problem by 60% because low voltage make sometimes these faults showing up.

Check your battery first.

Greetings from cloudy Greece!!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership