Jump to content
Do Not Sell My Personal Information


Engine Error because of throttle booster


Recommended Posts

Hello guys.

I am new driver and new to the club.

I have a Ford Focus Mk2 1.4 80Hp and i decided to install a throttle booster that i bought from ebay
https://www.ebay.com/itm/9-Drive-9-Mode-Electronic-Throttle-Controller-For-Dodge-RAM-Ford-Honda-Chevrolet/124094252704?_trkparms=aid%3D111001%26algo%3DREC.SEED%26ao%3D1%26asc%3D20160908105057%26meid%3D01ee849b296841d89bf62139277b2b15%26pid%3D100675%26rk%3D1%26rkt%3D15%26mehot%3Dpp%26sd%3D124094252704%26itm%3D124094252704%26pmt%3D1%26noa%3D1%26pg%3D2380057%26brand%3DUnbranded&_trksid=p2380057.c100675.m4236&_trkparms=pageci%3A51ddf92b-7c0e-11eb-99d0-9672f398f689%7Cparentrq%3Af7b63abb1770acf22d72dcf1fffbce26%7Ciid%3A1

 

The problem is when i plug it i get the following error: Acceleration Reduced, Engine Systems Fault and it get into limp mode.

When i disconnected it the error clear.

I plugged an obd reader to the car and i found the following error P2121(i attached a picture).

Is there any way to make it work or not?

Did anyone had a problem like that?

Thanks.

 

 

 

 

9 drive error.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership