Jump to content
Do Not Sell My Personal Information


Is my mild hybrid system working?


Recommended Posts

Had the car about 10 days.  I put the Hybrid Guage on screen a few days ago and when I slow etc it swings left into the green to show its capturing electricity.  I have not once see it swing right into the blue to show that the electric engine has kicked in.

Is it working?  How can I tell?

Link to post
Share on other sites

You know it's working when it swings into the blue as you described.

Mine does it up hills and sometimes on 'brisk' upchanges (especially accelerating on the 40mph ring road from a standstill), I didn't see it much around my estate at 30mph though. 

I'm not accelerating hard while running in so haven't seen it move from harsh acceleration alone so far, but it should also do it then.

I've only ever seen half of the blue gauge filled so far.

Link to post
Share on other sites

 

4 minutes ago, TomsFocus said:

You know it's working when it swings into the blue as you described.

Mine does it up hills and sometimes on 'brisk' upchanges (especially accelerating on the 40mph ring road from a standstill), I didn't see it much around my estate at 30mph though. 

I'm not accelerating hard while running in so haven't seen it move from harsh acceleration alone so far, but it should also do it then.

I've only ever seen half of the blue gauge filled so far.

I’ve never seen any blue at all!

Link to post
Share on other sites
2 minutes ago, Woodchal said:

I’ve never seen any blue at all!

Not quite sure how to ask this but...is your driving style quite 'sedate'? :biggrin: 

Seriously though, it will be driving style dependant so it might just b the type of roads you drive.  If it's all stop start town traffic on a flat road you're unlikely to see it.

Link to post
Share on other sites
2 hours ago, TomsFocus said:

Not quite sure how to ask this but...is your driving style quite 'sedate'? :biggrin: 

Seriously though, it will be driving style dependant so it might just b the type of roads you drive.  If it's all stop start town traffic on a flat road you're unlikely to see it.

Probably quite sedate, but only when my wife is with me 😝!  I’ll have to check it out with more revs when I’m on my own.  However I had thought it was meant to come in as you were pulling away, improving acceleration at this end of the range too.

Link to post
Share on other sites

9 minutes ago, Woodchal said:

Probably quite sedate, but only when my wife is with me 😝!  I’ll have to check it out with more revs when I’m on my own.  However I had thought it was meant to come in as you were pulling away, improving acceleration at this end of the range too.

It will happen when pulling away, but only if you put your foot down haha!  

Link to post
Share on other sites

Ok, well I’m happy to report that it is now going into the blue, with no major difference in driving style.  🤔 could it be that it was after a few miles in driving with the mild hybrid going into the green (charging) that the system could give some back by swinging into the blue.

Link to post
Share on other sites
34 minutes ago, Woodchal said:

Ok, well I’m happy to report that it is now going into the blue, with no major difference in driving style.  🤔 could it be that it was after a few miles in driving with the mild hybrid going into the green (charging) that the system could give some back by swinging into the blue.

Yeah, maybe it just hadn't charged enough before.  I've seen mine several times today, seems to be more and more as time goes on.

Link to post
Share on other sites
1 hour ago, MasterTechTip said:

You can get the bar to go all the way into blue if you give it full throttle for a few seconds 😉 

Possibly, but that was not my experience when I first got the car - it didn’t go into the blue at all!  Following earlier comments about a sedate driving style I tried that and nothing.  Then today after a longer trip and plenty of trips into the green it started making trips into blue - helping performance when accelerating from lowish speeds in 3/4 gear and then more generally.  I was speculating that it might be battery charge related - is that even possible?  If it is then perhaps a pre-delivery check should include a battery charge.

Link to post
Share on other sites

7 hours ago, Woodchal said:

Possibly, but that was not my experience when I first got the car - it didn’t go into the blue at all!  Following earlier comments about a sedate driving style I tried that and nothing.  Then today after a longer trip and plenty of trips into the green it started making trips into blue - helping performance when accelerating from lowish speeds in 3/4 gear and then more generally.  I was speculating that it might be battery charge related - is that even possible?  If it is then perhaps a pre-delivery check should include a battery charge.

Yeah more than likely the 48 volt battery was a bit down on power and needed some charge as you said. Unfortunately the 48 volt battery doesn't get checked on PDI and there is no battery tester for it that Ford supply. 

Link to post
Share on other sites
9 hours ago, Woodchal said:

Then today after a longer trip and plenty of trips into the green it started making trips into blue...

I was speculating that it might be battery charge related - is that even possible?

Don't forget it's not like a normal car battery which is always charged...with the MHEV battery you can only get out of it what you put in.  It needs a certain type of driving style to charge the battery, as well as to kick in the motor.

I think it could do with some sort of charge 'status' on the hybrid screen to show how much the battery is charged, rather than just whether it's charging or depleting.

Link to post
Share on other sites
9 hours ago, TomsFocus said:

Don't forget it's not like a normal car battery which is always charged...with the MHEV battery you can only get out of it what you put in.  It needs a certain type of driving style to charge the battery, as well as to kick in the motor.

I think it could do with some sort of charge 'status' on the hybrid screen to show how much the battery is charged, rather than just whether it's charging or depleting.

Not a bad idea I'll put it forward and see what sort of reaction it gets

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership