Jump to content
Do Not Sell My Personal Information


Charging system service now


Recommended Posts

Hi has anybody had this come up on dashboard charging system service now with red battery symbol comes on shortly after starting car battery was new last year and has plenty of charge in it just started last week car not being used a lot at moment due to shielding and if so how was it fixed tried flashing headlights 5 times then pressing brake pedal 3 times with ignition on but engine off battery light flashes 3 times at end but charging system service now comes back up 

 

Link to post
Share on other sites

Hi I don't have an Edge but I have this on my Focus Vignalle the car was purchased new Oct 2019 and the first time this message came up was TWO days after I picked the car up from the dealer and it has happened approx NINETY FIVE times to date. It went back to the dealer four times between Oct 2019 - Feb 2021 where they initially said it may be a duff battery but after having it on charge over night and testing the following day they said the battery was OK and returned the car having reset the system but  the warning always comes back sometimes after a couple of weeks or it can happen after a couple of miles it can happen once or twice in a long journey but I have had it happen up to eight times in one day.

I gave up trying to get it sorted by the dealership as they were having the car more than me so I have more or less resigned myself to putting up with the problem and just press the OK Button and the message will disappear for a while however when this message comes up the car also initiates a few other faults: (A) Keyless Entry on Passenger Door and Boot is disabled (B) Radio will not operate with the Ignition off (C) Start Stop does not work. To  be honest the Start Stop does not bother me at all and I can live without the other two but they should all work on an eighteen month old car

I will probably hand the car back at the end of the three year PCP contract and try a different manufacturer which is a shame as I have had Fords for over 35 years but this one is not good and I have lost all trust in the brand  as like a lot of people I don't have a problem with anything mechanical going wrong but I do have a problem when the Manufacturer Trained Technicians can't fix it.

I keep looking at articles on YOUTUBE hoping that the guy called SY Diagnostics will one day do a VIDEO of this problem as he certainly seems to know his stuff I wish I knew where he was based as I would gladly pay him to sort my car out and forget the worthless FORD Warranty.

Just a thought you say that you had a new battery last year so was it the correct type for the vehicle i.e was it a STOP/START battery you had fitted.

Hope you get sorted  

  

Link to post
Share on other sites

Yes it is definitely the correct battery and has run okay for about six months only started when I connected trailer the other day to do a tip run if you stop car turn off then restart it comes back on in three or four minutes maybe need to go check every fuse I can find in case it blow one with led trailers lights not had a problem before with same trailer but you never know cars are to complicated now 

 

Link to post
Share on other sites

I have tried taking battery off and recharged it to full power but it did same when reconnecting starts and runs fine stop/ start does not work 

Link to post
Share on other sites

Also have the same issue, new battery, new Alternator (not recon) still same. Multimeter showing 14v when running via battery even when battery light light on dash. Stop car re-start light off 4-5 minutes light back on

Link to post
Share on other sites

Sounds like a smart charge system fault which is the wiring off of the alternator that runs to the PCM and battery monitor, you could have a wiring fault. I've known active grille shutters to cause the battery light to come on as they share the same LIN bus wiring with the charging system.

Link to post
Share on other sites
  • 2 weeks later...

Had car in to ford dealers today left it diagnosed As alternator failure so they are going to fit new alternator £904.80 fitted told them I am not paying for it if it does not fix problem they showed me the diagnostic picture that says it is not charging and that it is putting out less than 11.5 volts so fingers crossed that it fixes it The battery that the aa diagnosed as buggered in July after I recharged it a couple of times now after ford garage checked it today is 100% good plus is the replacement I purchased in July on the aa s say-so   

Link to post
Share on other sites

Had car in to ford dealers today left it diagnosed As alternator failure so they are going to fit new alternator £904.80 fitted told them I am not paying for it if it does not fix problem they showed me the diagnostic picture that says it is not charging and that it is putting out less than 11.5 volts so fingers crossed that it fixes it The battery that the aa diagnosed as buggered in July after I recharged it a couple of times now after ford garage checked it today is 100% good plus is the replacement I purchased in July on the aa s say-so   

Link to post
Share on other sites
51 minutes ago, Ydda2 said:

Simon please can you tell me ware alternator excitation fuse is 

Fuse F55 (10A) in the battery Junction Box (BJB) is the B+ to the alternator ... Fuse F8 (275A) in the BJB is the fused alternator output to the battery.

Although, saying that, like most modern cars, the PCM controls charging in that when you put your foot down it drops the load caused by the alternator by removing the excitation feed, decreasing the load on the engine when you need it most (part of the smart charging strategy), so the physical alternator is just one part of a more complex system!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership