Jump to content
Do Not Sell My Personal Information


Mondeo mk4 immobiliser active, engine malfunction and obd11 not connecting problems,


Recommended Posts

Hi all, here is a rather unusual story, I think and I'm hoping someone can throw some light on it for me.

My car is a 2010 Mondeo 2.0 diesel estate car.

The car was parked up around six months ago and the not used as I was working from home, because of covid etc. I did give it a wash with a pressure washer while I had it out cleaning a path and later found the battery was dead. I charged the battery, after which the dash came up with the error messages of immobilser active and engine malfunction and I have tried lots of things, but it doesn't attempt to start as it always comes up with these messages. I have bought a number of cheap diagnostics code readers, but non will connect to the car, they all say failed to connect, but they have power to them because they are waiting for the car to respond. I have replaced the battery and it turns the engine over if I put a wire across the relevant relay (without the ignition key being turned to start), this I did to ensure that there was no problem with the starter etc. Also when I did this I sprayed some easy start into the air intake and it did fire, so I think that the fault is not with the engine either. The fob locks the car as it should and the lights, radio, fan etc all function and the dash lights up as usual except for the error messages and the beeping.

I have tried the key reprogramming   by turning on off ignition 4 times etc and this hasn't helped.

I have checked and cleaned all fuses and relays and cleaned all the earth terminals I can see.

I am at a loss, but am starting to suspect that there is a communication problem with the pcm, possibly caused by a wiring issue. Hence it not connecting to the OBD port. I found power to the red wire and the yellow wire that go into the pcm both have 12 volts, so could it be that there is no earth at the pcm or another wiring issue? My expertise really ends with testing for 12 volts, but I hoping someone much clever than me can point me in the right direction. 

Please don't suggest I take it t my local dealer, as I live on the Isle of Arran and can't get the car to a dealer without considerable expense, as it is not drivable in its current state.

Thanks if you've read this far

Ever hopeful

Pat

Link to post
Share on other sites
15 hours ago, Patrick Mowatt said:

I am at a loss, but am starting to suspect that there is a communication problem with the pcm, possibly caused by a wiring issue. Hence it not connecting to the OBD port.

I think you are right to suspect a communications problem.
The first step is to check resistance at the OBD port between PINS 6 & 14.
You should have a reading of 60 ohms if the coms BUS wiring is good.

OBD.jpg.bfd1f29e3fb9ba6b9f5ee94770620835.jpg

Link to post
Share on other sites

Hi Dan62, thanks for your helpful suggestion and the diagram! I have now just checked them and there is close to 60 ohms between those terminals, so I'm guessing that it means that the pcm is working. I noticed that a relay does click somewhere on the pcm when I turn the ignition on. 

I call it the pcm, but please correct me if I am wrong! It is located under the glove box on the passenger side (left side) and has three large connection sockets and two smaller sockets.

Also when I checked all the wiring plugs they have been clean and dry.

Any further help will be appreciated! 

Kind regards, Pat

Link to post
Share on other sites

60 ohms on the OBD connector means the CAN BUS wiring is good.

The diagrams I have are not great for Mondeo.
The box you're calling the PCM is the Auxiliary fusebox or BCM, the PCM is under the bonnet.

If you can take some pictures of the fuseboxes, both under the glovebox and the one in the engine compartment it might help me track down a diagram.

Seeing as is not looking like a CAN BUS issue, you could have probably popped a fuse when  you put the battery on charge.
Bit of a pain to work through the fuses one by one but think its the next step.

Have seen a similar issue before and its usually one of the low current fuses that pops, don't think you'll have any 3A fuses but start with the lowest fuse ratings first, it might save you time.

Link to post
Share on other sites

Fuse 10 in the Engine fusebox might be a good place to start, should be a 10A fuse if I'm looking at the right circuit!

Link to post
Share on other sites

Thanks again Dan62!

I've attached some pictures of the fuse boxes. I have already painstaking taken out each fuse and checked them, including the 60 and 80 amp ones hidden down the side of the engine fuse box and all the ones in the inside as well. The lowest amperage fuse I have found is 5A. Someone put a clip on youtube of a fuse that can blow, but but that is fine, although when I took the fuse box out, I found three r/w wires crimped together (by Ford) that look as though they should be supplying power to three relays, but aren't. After discovering this, I put a wire across the relay second down on the left of the picture, after removing the relay and the engine turns over fine, so after this and what you've already told me, I'm back to thinking it could be a key not being recognised, but still don't see why that would make the obd port inoperative.

Pat

 

IMG_7089.JPG

IMG_7088.JPG

IMG_7091.JPG

Link to post
Share on other sites

I'm really not up on Mondeo's.
Do you have a flashing immobiliser light on the dash / instrument cluster as well as the immobiliser active message?

If so they usually flash rapidly if there is a key fault then flash a 2 digit code

 

Link to post
Share on other sites

Hi Patrick, looks like you have managed to get the BCM (inside fusebox) out from under the dashboard (not easy). With the battery disconnected unplug the cables going in to the BCM and check the pins carefully for signs of corrosion.

Have you got more than one key for the car ?

Link to post
Share on other sites

Hi, Dan62 and Unofix, thanks for your comments.

Dan62, yes there is a flashing ! (question mark) on the dash and also the display has messages immobiliser active and engine malfunction displayed and an audible beep I think three tines when turned on.

Unifix, yes I did manage to get the BCM out (don't know how I'll get it back again, but I'll worry about that when the time comes) and have carefully checked all the pins and it all looks like new, no corrosion at all, please see pictures. I do have two keys, but have tried reprogramming them, only finding out that this is a definite no no since doing it.

Is there any way that a key can be sent away and programmed to the car? 

Regards, Pat

 

 

 

IMG_7092.JPG

IMG_7095.JPG

IMG_7096.JPG

IMG_7097.JPG

IMG_7099.JPG

Link to post
Share on other sites

Hi Pat, excellnt pictures, which is a bit sad, would have been better to have seen a problem.

The car keys contain a transponder chip which the cars security system reads when the key is in the car. The ability to reprogramme the car to the key by the driver was removed by Ford many years ago and I don't think anything you could have done would have caused the keys to be come de-programmed from the car. Yes you still can reprogramme the key buttons for the remote lock/unlock but that does not stop the car from starting.

Keys can be progrramed in, and out, of the cars security system using ForScan (with extended licence), its the car that gets programmed to the key. But at this stage I don't think it the cause of your problem.

If you have a fast flashing red alarm light when you try to start the car then it is a case that the security system has not recognised the key but that can be for a number of reasons.

If we try an look on the positive side of things this maybe just a glitch. Try reconnecting everything except the battery, leave that off for just now.

With both battery leads totally disconnected from the battery, short the positive and negative battery leads together for a couple of minutes. Make sure you place one key inside the car and then reconnect the battery as normal. Then try the ignition again. Let me know how it goes

Link to post
Share on other sites

I've disconnected the battery and shorted the leads together for a few minutes using mole grips to ensure they stayed shorted,  then reconnected the battery and no change at all to report. I turn the key and the messages still come up and the obd reader fails to connect, it tries and waits for the car to respond and I guess it times out.

The more I think about it, the more I think that the keys aren't being recognised by the car.

Link to post
Share on other sites

Hi Pat, it was a long shot but worth a try. You are right that it does seem that the keys are not being recognised but is the fault the key(s) or that the transponder reader in the car has a fault ?

I think you should invest in an ELM327 lead (£20) and download ForScan (free) on to a laptop. At least that way you could be sure if there was a problem with the OBDii port, and if there is no problem then you would be able to read the DTC (fault codes)

 

Link to post
Share on other sites

Hi Unofix, unfortunately I have already purchased an ELM lead and downloaded Forscan, but the problem persist with no connection, so nothing can be checked. I've attached a couple of pictures taken this morning.

The plug is properly plugged into both the OBD port and my laptop, so I think I have now reached the end with the car.

Thanks for help in trying to resolve the situation!

Kind regards, Pat

IMG_7100.JPG

IMG_7101.JPG

IMG_7102.JPG

Link to post
Share on other sites

Hi Pat, sorry to hear the bad news. There is a guy who does YouTube videos who is excellent in finding faults and from what i have heard will offer good advice via e-mail.

It might be worth dropping him a line he operates under the name of "SY Diagnostics" (He is not Ford) you can find him on facebook I think.

https://www.facebook.com/skodayoda/

SY Diagnostics
Hartwell Ford
Rendel Street
Grimsby

 

Link to post
Share on other sites

Hi, I've read about this before on forums... you are not alone! I'll have a forum  search to see what was the resolution, if any. 

btw, on my mk3 Mondeo, if I put an unchipped key in the ignition and turn it on, I can still connect to the ecu, and get an error message about pats key unable to be read, but it is still able to communicate with the ecu.. 🤔 

Try this one:

https://talkford.com/community/topic/151319-immobiliser-active-message-engine-will-not-start/

 

and these:

https://talkford.com/community/topic/216204-inmobilser-active-help/

 

https://talkford.com/community/topic/239043-engine-malfunction-immobiliser-active/page-2

 

https://talkford.com/community/topic/334273-intermittent-starting-problemengine-malfunctionimmobiliser-active/

 

This one goes really deep.... 

Let us know how you get on! 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Forums


News


Membership