Jump to content
Do Not Sell My Personal Information


Forc Focus media screen blank/not working


Recommended Posts

I've just picked up a 22 plate Ford Focus company car with 26 miles on the clock. The screen is blank and has been so since I picked the car up. I've restarted the ignition numerous times but to no avail, which means I cannot use radio, satnav, connect to bluetooth etc. Any advice?

Link to comment
Share on other sites


Press the on/off button and forward button together and wait a few seconds until the sync screen reboots. 

Link to comment
Share on other sites

Disconnect the battery negative terminal for 20 minutes before reconnecting it. My thoughts would be that the battery was flat and they jump started it before delivering it which can often cause this kind of problem.

Link to comment
Share on other sites

9 minutes ago, iantt said:

Press the on/off button and forward button together and wait a few seconds until the sync screen reboots. 

Tried this and it doesn't work

Link to comment
Share on other sites

27 minutes ago, Andrew watts said:

Tried this and it doesn't work

A call to the dealer tommorow then. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership