Jump to content
Do Not Sell My Personal Information


Mondeo Titanium X business mk 4.5 Sat Nav "Insert original data carrier"


Recommended Posts

Hi,

 

I've got a Mondeo titanium X business edition. 2014 reg. Mk 4.5 I believe. 

I'm unsure what headunit I have, but the standard one in this car. 

 The DAB doesn't seem to work, there's an option for it, but it doesn't do anything. Tried pulling fuse, putting radio code back in and no dice. 

Another bug bear is my sat nav was temperamental, sometimes saying "please insert original data carrier" I could unplug the SD card, plug it back in, it would load and happy days. It seems to not do this anymore. I've taken the SD card out and plugged it into my laptop, checked for errors and it appears absolutely fine. 

anything else I can try? I'm assuming it's the card reader :/. If anyone has any experience with this please let me know. I see loads of info for the older head units with a disc but believe mine doesn't have a satnav disc just sd card?IMG_20220803_064014.thumb.jpg.5ae7ccce5ba3d6da7b0719b0da3783a3.jpg

Link to comment
Share on other sites


On 8/3/2022 at 10:57 AM, unofix said:

Your SD card is well out of date. I'd try replacing it with the latest version (under £20).

https://www.ebay.co.uk/itm/125389429717?epid=9035915094&hash=item1d31cadbd5:g:RjUAAOSwY39hxzmj

Hi, received the card today. Still exactly the same issue  "please insert original data carrier" 

Know of anything I can try now?

Link to comment
Share on other sites

The original could well be a DVD not the SD card.

The error message usually means that the disc is damaged, or just dirty, and cannot be read.

It's well hidden, this youtube video reveals its location.  https://www.youtube.com/watch?v=5L5N-yZdYKI

 

Link to comment
Share on other sites

47 minutes ago, ris001 said:

The original could well be a DVD not the SD card.

The error message usually means that the disc is damaged, or just dirty, and cannot be read.

It's well hidden, this youtube video reveals its location.  https://www.youtube.com/watch?v=5L5N-yZdYKI

 

My headunit doesn't have a DVD for nav. Just an SD card. 

 

IMG_20220806_134507.jpg

Link to comment
Share on other sites

That's very disappointing news. It's almost as if it has the wrong software loaded, but since it has worked in the time you have owned the car I think we can probably rule that out.

I'm not familiar with the loading of the SD in to that style of head unit. Does the SD card seem a good fit in the slot, or could there have been a frame that the SD card might have been intended to fit in before inserting in to the slot?

I will see if I can find any more information on the unit you have.

Link to comment
Share on other sites

1 minute ago, unofix said:

That's very disappointing news. It's almost as if it has the wrong software loaded, but since it has worked in the time you have owned the car I think we can probably rule that out.

I'm not familiar with the loading of the SD in to that style of head unit. Does the SD card seem a good fit in the slot, or could there have been a frame that the SD card might have been intended to fit in before inserting in to the slot?

I will see if I can find any more information on the unit you have.

 Cheers for the input so far. 

 

It clicks in lovely as you'd expect. It's kinda sprung, you push it, it clicks in. Push it again the spring pushes it out slightly. 

I'll try cleaning it with 99.99% IPA and cotton bud tomorrow I think. Incase it's got any crap / dust build up in there.

Link to comment
Share on other sites

Just a very quick update.

Firstly the SD card should never be ejected unless "Eject" has been selected from the service menu.

It seems that the unit you have with the touch screen is quite rare and that it could copy software updates and the operating system updates form a DVD inserted in to the normal CD drive. The updates are then copied to the SD card and the DVD is then removed. This might be what it keeps asking for

8 hours ago, Helios said:

"please insert original data carrier" 

I can't be a 100% sure that this information is correct but will keep looking and see if I can find more.

Link to comment
Share on other sites

The option to remove sd via the button is greyed out. Unpresseable. As if the card isn't even in the slot at all, which I think further reinforces the sd reader is up the swanny. 

 

I'm yet to try cleaning it with IPA. Hopefully there's some dust in there. 

Like what happens with my phone from time to time. Although the SD card slot always has a card in and is covered by the little panel, can't see how it'd get a dust build up, but worth a try. There was no sign of corrosion on the SD card itself, so likely none on the reader. 

 

 

Link to comment
Share on other sites

Little update. I got the original SD card working...

Things I did;

Pull the fuse for 10 mins, I had dab working for a couple mins ish, then it turned the headunit off and wouldn't turn back on. 

Pulled the positive terminal off the battery for 10 mins (because getting to the negative is an absolute faff!), dab doesn't work, sat nav still had insert data carrier. 

Reset nav settings on the menu.

Went for a drive, unplugged and plugged in the different SD cards several times. The "eject SD card" and "Sd card info" buttons never lit up. Then one time the SD card loaded and sat nav's fine. 

The new SD card doesn't load at all, I actually think it's not for my car as don't think I have sync 2!? Just messaged the eBay seller to see if I can send it back. 

 

So which of my attempts above do I think helped? None of them, I still think the SD reader is crapping out. I'm hoping it will carry on working, but from past experience, it won't! 😞

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership