Preee

Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

Recommended Posts

i'm almost certain the ones on the right HS can were the ones giving me N/A in all the boxes...

Share this post


Link to post
Share on other sites
 

i'm almost certain the ones on the right HS can were the ones giving me N/A in all the boxes...

irl-06lx if you look at your picture you have GEM selected on the left which is the side that requires the cable mod.

If you get any install probelms of the DLL'S in win7 64bit , then "run as administrator"

If you get any errors under win 7 64 then start the program "run as administrator"

Share this post


Link to post
Share on other sites

I GOT IT!!!!

thank you to everyone who has helped put this together, its amazing. Somethings to note on my part, that may seem common sense to others or that i just missed in these 12 pages!

1. you need your ignition on... :( oops

2. english makes it so much easier!

main thing really is that although my image above has gem selected, that was just the time i took the screenshot, all the right hand side modules were doing the same.

the reason for this was that the ignition was off! I rewired for gem and it still happened on the gem module and im not sure what it was, but something in the error made me turn the ignition on!. all working now.

One small thing, I'd love to put in the switch(es?) but my knowledge of wiring diagrams is limited at best. can anyone just say between what wires i should put the switch (or is there more than 1 needed?)

So far I've made it deadlock with one press, turned on CC in the GEM and made it auto lock after 7kph.

thanks folks!

Share this post


Link to post
Share on other sites

Just enabled the DDS and the eco mode :) using the newer EMLconfig was really easy and didnt have to chop apart the adapter either, wonder if ford will notice when it goes in for its next service

Share this post


Link to post
Share on other sites

Because it was on the BCM on the right hand list of modules on the EML Config software you dont need to mod the adapter for read and write from these. so paid 9.99 for the EML adapter off ebay and enabled the £75 optional extra. Happy man :)

Share this post


Link to post
Share on other sites

£75!!

Good stuff, I need to rewire mine back or ideally put switches in but not sure which wires they go on

Share this post


Link to post
Share on other sites

on the first page is a lay out if you turn the switch over you will see 6 pins to solder on too. lets call them pin

1 2 3

4 5 6

on 2 you would solder Can-L and on 5 solder Can-H

on 1 you would then solder the connection that goes to pin 11 on the EML and pin 3 would go to connection 14 on the EML

on 4 you would solder the connection that goes to pin 3 on the EML and pin 6 would go to connection 6 on the EML

The switch will have 3 places where it will click dead centre will be off and then to the left or right will enable either the higher or lower connections to what you needed

This post is only from what i can tell from the pic and the switch that has been linked to too. not sure if its someone i would want to do as i dont like self locking doors and the global window open and closed dont seam to be able to work unless you have electric windows all around.

Share this post


Link to post
Share on other sites

Just enabled the DDS and the eco mode :) using the newer EMLconfig was really easy and didnt have to chop apart the adapter either, wonder if ford will notice when it goes in for its next service

How did you get DDS on? BCM -> DDS put it on there? Nothing else?

Did you see this option (after you have done this) on your dashdisplay?

I did put the DDS option on, but nothing appears on my dash display. I did manage the locks and eco mode. But DDS failed. :-(

Share this post


Link to post
Share on other sites

You also need to enable the DDs on the Dash module which is HEC module so that the dash can tell that its enabled.

Share this post


Link to post
Share on other sites

can you be more specific please, i did check the HEC but couldn't find something overthere what was something like DDS. :wacko:

Or do you mean i have to thick box... EPB (level 1) / DDS (Level 2/3) in HEC -> config ->page 1

Share this post


Link to post
Share on other sites

can you be more specific please, i did check the HEC but couldn't find something overthere what was something like DDS. :wacko:

Or do you mean i have to thick box... EPB (level 1) / DDS (Level 2/3) in HEC -> config ->page 1

Thats it tick that box and it should all be done

Share this post


Link to post
Share on other sites

What is the DDS feature?

is it tyre pressure?

if yes do we not need to install some sensors too?

Share this post


Link to post
Share on other sites

its tyre deflation detection system, no extra parts are needed as it runs off the abs sensor on each wheel. It wont tell you what each tyre is at, but will tell you if the tyre is deflated as that while will be running slower than the rest pump ur tyres up to correct pressre then set the levels on the trip computer and the let computer do the magic

Share this post


Link to post
Share on other sites

I noticed someone posted you have to have the ignition on do mean car started or when the dash is lit up like a Xmas tree, as I have starter button do I assume I press that once without starting the car?

Share this post


Link to post
Share on other sites

its tyre deflation detection system, no extra parts are needed as it runs off the abs sensor on each wheel. It wont tell you what each tyre is at, but will tell you if the tyre is deflated as that while will be running slower than the rest pump ur tyres up to correct pressre then set the levels on the trip computer and the let computer do the magic

Tyre pressure monitoring activated.......another feature added :)

Share this post


Link to post
Share on other sites

its tyre deflation detection system, no extra parts are needed as it runs off the abs sensor on each wheel. It wont tell you what each tyre is at, but will tell you if the tyre is deflated as that while will be running slower than the rest pump ur tyres up to correct pressre then set the levels on the trip computer and the let computer do the magic

thats excellent thanks,

ill activate mine when i get home from work today :D

Share this post


Link to post
Share on other sites

A word of caution.

I used the Elm-FF2 to setup auto lock at 7km/h, working. Unlock only drivers door on first press, works great. The nice thing with ELM FF2 is that it disables options that are not valid for my model (MK2- pre facelift).

I just tried using Elm Config (English version) to turn on DDS, but kept getting a CAN error on writing (could read OK though, so ELM interface working). I then tried ticking EPB (Level 1) / DDS(Level 2/3) and writing. This seemed to write, but my dash display said EPM Total failure, so I turned it off again.

Now the not so good part:

Under GEM I read the configuration OK, and saved it away (all threes pages). I then ticked Slam Central Locking, and Wrote to GEM. Since then I canot read or write the GEM module. I even tried the Reset Module procedure. All I get is "Invalid Response"! Car still runs, thank god.

Any ideas how I might recover the situation? (I tried Elm FF2 again, and the BCM tab no longer connects, or reads from the module)

Share this post


Link to post
Share on other sites

Mr.Grumpy seems to be not so grumpy any more ;)

Well I tried doing it again after my laptop crashing the other day and now it wont work at all, I have taken all files out and downloaded them again. It came up with the mscomm error so i downloaded the dll files moved them to the system 32 folder, ran it as admin and it still comes up with mscomm error.

So i am still MrGrumpy :P

Share this post


Link to post
Share on other sites

See my post above. Don't put files in system32. Put them straight into the windows folder an run as admin. make sure user account control is off. You need to restart after you turn it off then run the RegDll as admin (right click to do this)

All should be grand then

Share this post


Link to post
Share on other sites

See my post above. Don't put files in system32. Put them straight into the windows folder an run as admin. make sure user account control is off. You need to restart after you turn it off then run the RegDll as admin (right click to do this)

All should be grand then

Dunno what I was doing but ive done it and it all loads up, but for some reason it wanted to open my CAD software to view something but cancelled all that and it loads up fine.. now to turn on some goodies.

now im guessing all the instructions i need are on that first post? I wont be modifying the unit as im not that good unless i need to modify the box for something i actually want/need to activate to which ill get someone professional to do.

Share this post


Link to post
Share on other sites

Well I tried doing it again after my laptop crashing the other day and now it wont work at all, I have taken all files out and downloaded them again. It came up with the mscomm error so i downloaded the dll files moved them to the system 32 folder, ran it as admin and it still comes up with mscomm error.

So i am still MrGrumpy :P

i had the same trouble mate,

only difference was with me, i had deleted some software that came with the ELM327 but the software i had deleted shared some files with the software i wanted to keep,

as result the software i kept couldnt run so i performed a system restore to 3 weeks previous then downloaded the software i wanted, now the software works but i need to set up the COM port for the ELM 327

hope this helps mate.

Share this post


Link to post
Share on other sites

I have not downloaded anything other than the software on post 116 and the first EMLff2 no dll packs or anything and everything has worked that i have tried

Share this post


Link to post
Share on other sites

A word of caution.

I used the Elm-FF2 to setup auto lock at 7km/h, working. Unlock only drivers door on first press, works great. The nice thing with ELM FF2 is that it disables options that are not valid for my model (MK2- pre facelift).

I just tried using Elm Config (English version) to turn on DDS, but kept getting a CAN error on writing (could read OK though, so ELM interface working). I then tried ticking EPB (Level 1) / DDS(Level 2/3) and writing. This seemed to write, but my dash display said EPM Total failure, so I turned it off again.

Now the not so good part:

Under GEM I read the configuration OK, and saved it away (all threes pages). I then ticked Slam Central Locking, and Wrote to GEM. Since then I canot read or write the GEM module. I even tried the Reset Module procedure. All I get is "Invalid Response"! Car still runs, thank god.

Any ideas how I might recover the situation? (I tried Elm FF2 again, and the BCM tab no longer connects, or reads from the module)

What i would try first is on page one of this guide , get your AS-Built data for your Vin number from the website , connect to your car with ELM-FF2. Use the load AS-Built for GEM and find the correct default value then click send to return to default using the AS Built data for your VIN number.

Or can you connect with ELMconfig by means of load your saved default file then select SEND , meaning connect via com port , load file then send don't try and read.

*EDIT* from what i have just read DDS was not available until the facelift Model Mk2.5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now