• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience


DazzaRS

Focus Mk 2.5 Heated Seats

Recommended Posts

having some issues on getting my heated seats to work

i have the ford's own heated switches in place and plugged in

i managed to get heated elements from a 2007 ford focus ST leather seats

i have the wires in places in the loom

i have volts in the intake for the switch but doesnt vary its 0v @ 0 and 12v @ 1-2-3-4-5

i have the ign feed going to under seat thats from the gem module fuse 121 to engine bay fuse box.

any ideas would great full

Share this post


Link to post
Share on other sites

wish i could help but electrics aint my forte, not since plugging in a battery powered r'c motor into the mains when i was 6!

flew me across the room when i switched it on and it went kaboom!

Share this post


Link to post
Share on other sites

Can you show pics of the connection to the seats module. And the connections of the seats ,with the module detached. And a pic of your fuse box, remove the orange big plug and show pic of that. And a pic of the fuse box fuses. Hopefully I should find out what's wrong.

Share this post


Link to post
Share on other sites

Yes fuse 121 20a

In place and power running through it

Share this post


Link to post
Share on other sites

Iam a electrician I have traced all wires and can confirm there is power under the seat

Share this post


Link to post
Share on other sites

So all you need to really do is just put the pads in and done.

Share this post


Link to post
Share on other sites

So all you need to really do is just put the pads in and done.

No, they wont heat up

Share this post


Link to post
Share on other sites

Ok check if the pads have a complete circuit as there might be a break in them. Then check if there any power going throught the heated seats fuse. And you need a fuse also for the seat modules. It's a 10 amp fuse. Just rembered. Check the fuse voltage with the switches put on 5. Have you installed the switches if you have do the turn on nilluminate with the headlamps.

Share this post


Link to post
Share on other sites

Ok check if the pads have a complete circuit as there might be a break in them. Then check if there any power going throught the heated seats fuse. And you need a fuse also for the seat modules. It's a 10 amp fuse. Just rembered. Check the fuse voltage with the switches put on 5. Have you installed the switches if you have do the turn on nilluminate with the headlamps.

read first post.....

the 10A you mention is the power module supply

they illuminate with dash

Share this post


Link to post
Share on other sites

Yh read it the switches don't chance temp it's the termo that's in the pad so you should be seeing a 12 for each setting. . Are the pads working have you check if it a complete unit?

Share this post


Link to post
Share on other sites

update

i placed in different ford elements and they worked why didnt the recaro ones work? very strange

Share this post


Link to post
Share on other sites

I wonder if the Recaro seats are faulty then ?

Share this post


Link to post
Share on other sites

will be testing from where they come from today but theres not damage to them

Share this post


Link to post
Share on other sites

Does seem very strange , you put a lot of time tracing the wires and testing , only to find the wiring was working , i bet your not happy.

Share this post


Link to post
Share on other sites

Does seem very strange , you put a lot of time tracing the wires and testing , only to find the wiring was working , i bet your not happy.

in a way yes but glad to find out it does work but the issue is the elements that work on my car I dont think they will fit into my seat

Share this post


Link to post
Share on other sites

update again... just plugged them into a 07 plate st and they worked straight away.... the gem must control it somehow as the loom is identical

Share this post


Link to post
Share on other sites

Very strange , at least you know they are working , so whats your next step are you going to look for an ST Gem or try and modify the seats

Share this post


Link to post
Share on other sites

comparing the the pads it really shouldnt be a issue the back part will be spot on.

Will be going to SF car trim in Colchester to have them professionally fitted

Share this post


Link to post
Share on other sites

also been made aware that facelift ford focus has a module to operate the elements and pre facelift didnt.

it raises a few questions is the elements differ from the versions of the focus and giving them different part numbers

Share this post


Link to post
Share on other sites

Just hope you dont get a burnt backside lol my vw ones went faulty once not good when you cant stop and youre bums burning

Share this post


Link to post
Share on other sites

would anyone know why a 2010 focus heated seat element for leather is £74 compared to the partial leather is £146

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now