womble68

Focus 1.6Tdci 58 Plate

Recommended Posts

don't know where to turn now.... my focus developed a engine malfuction fault , basicly it's stuck in limp mode , it's been into 3 different garages and no one can find whats wrong, the main deal had it for a month and couldn't find the fault they just said the cluster needs replacing at a stupid price , i have sent the cluster away twice to be checked and both time came back in full working order according to the company i havent got the money just to replace the cluster just to see if it that which is what the dealer has said i need to do just for elimination process, everything works ok apart from being stuck in limp mode no the mot has run out and i cant get a new one till it's sorted , anyone able to offer any advice , had the accelerater pedal replaced and that didnt solve it either spent over 600 quid so far on labour and parts and still no joy

Share this post


Link to post
Share on other sites
 

air filter was replaced a 3 months ago fuel filter last service which was 12 months ago so i'll give that a try cheers,

Share this post


Link to post
Share on other sites

Just put laptop on and 2 codes keep coming up P0620 generator control circuit and Part pedal sensor outputs disagree

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now