Cunning Stunt

Red Warning Light

Recommended Posts

Hi Guys,

Im new to this forum so hi, im from Edinburgh currently driving about in a 56 plate 1.8TDCi Focus!

Since i bought the car from the b******s that are Evans Halshaw iv had nothing but bother with the car. Light bulbs blowing, new brake disks and pads are only 2 of them that I can think of off the top of my head.

My latest issue is one that im not too sure about... the wee red exclamation mark with a cog round it comes on when the engines cold (AKA in the morning) and limits power to the engine. However it turns itself off after a couple of miles once the engines heated up. Iv done the onboard diagnostic and theres no error codes even when the light is on. I think this is something to do with my windscreen washers which were very low pressure, turns out the left hand one wasnt plugged in correctly (leaking into the engine lagging which is now a bit mouldy). Any ideas before I take it up to my mechanic?

Also is there any way to adjust my windscreen jets vertically now iv fixed them?

Cheers very much!

Liam

Share this post


Link to post
Share on other sites
 

I had a similar problem, the red light was on and the revs were limited, I drove it for a couple of days to work and back which was only a couple of miles so I can't say if the light would go out. I also got an error code which was related to the glow plug circuit ... I changed the glow plugs and the problem went away, £26 from the local motor factors. If you do decide to change them, you'll need a DEEP 10mm socket :)

Lee.

Share this post


Link to post
Share on other sites

How long have you had the car for? you got 6 months warranty with any garage/dealer regardless of what they say

Share this post


Link to post
Share on other sites

Iv had the car since the beginning of October so just under 5 months. I do 600+ miles a week with work which is where the problem lies if its a serious issue.

With the brake problems I had I nearly crashed and when I phoned Evans Halshaw where I got the car the guy just said it wasnt there fault and hung up on me. Was ready to go up and stick the nut on him so no doubt hel try that again and I'll end up getting arrested for assault.

Il speak to my mechanic tonight. and see what the problem is. As iv said, its on when the engine is cold (winter cold its not like this when its above 6-7deg in the morning) then it switches off within 2-3 miles and then the engine feels totally fine.

Cheers

Liam

Share this post


Link to post
Share on other sites

could be something which is damaged with the leaking water, or could be the glow plugs, but yeah get a mechanic to give it a good once over and take it from there

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now